Fordmods Logo

no dashlights/shifter lights & constant fuse blowing on a ef 

 

Page 1 of 2 [ 16 posts ] Go to page 1, 2  Next

 
 Post subject: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sat Jul 19, 2014 8:43 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

hey fellas ive picked up the ef xr6 and now in the middle of stripping it down, so while I do this were still driving the car around as it is and ive come to a bit of a problem im hoping yous can help me figure out.

so the cars a 1995 ef falcon futura wagon auto and a few days ago I was driving home late night and heard a small pop then lost all dash lights and shifter surround lights, obviously this is a fuse so I went down the next day bought a variety pack of fuses and replaced it with the same amp/colour fuse I pulled out and all was good until..... driving to get some tea last night same thing happened pop and no dash lights so I quickly got tea and drove home finding it hard to see the dash and speedo. today I went out there and pulled the fuse now heres were it gets interesting.

the fuse that was originally in it was a yellow 20amp replaced with same fuse (new one that blew) so looking at the fuse box I noticed that the park light fuse (ie park lights,dash lights, ect) was ment to use a 30amp green fuse so I replaced the blown 20amp with a 30amp hoping this would fix the problem (lucky I bought a variety pack), turned the lights on and pop straight away blew the 30amp.
put another in and same thing so here we come to a few questions I got hping you blokes can help.

1) why if there ment to run 30amp was there a factory 20amp in?

2) what could be causing it to keep blowing fuses in stumped on this one but since the car is needed at night its a issue I gotta fix asap?

3) when I resolve the issue do I put another 20amp like the original one or do I use the 30amp like it states on the fuse panel?

thanks for reading and hopefully you can help me resolve this issue without going to a auto elec. I look forward to reading your replies and in advance thanks for all your help
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sat Jul 19, 2014 9:25 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Hmm. Sounds like this should be in the auto electrical forum. :wink:

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sat Jul 19, 2014 11:01 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

yeah I realized I posted in the wrong section after I posted it, unfortunately theres not much I can do about that now.

so any suggestions people? I realy cant figure out whats going on and had to drive the car to pick dad up from a work party at 9pm was really difficult due to no dash lights lol.

any advice or anyone here had the same or similar issue or should I just take it to a auto elec on Monday pay the cash and be done with it. hoping it didn't come to that didn't wanna spend more cash on the car but what can ya do there a money pit but we love em. :D

also thanks to whoever moved it to the right section I couldn't figure out how so cheers for that :lol:
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sat Jul 19, 2014 11:09 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

have you tried working out which part of the lights is shorting it out???


to short out eitha a 20 amp OR a 30 amp fuse you have a MAJOR short :|
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 12:50 am 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

that's what im trying to figure out, I still don't understand why there was a 20amp in there in the first place if it was ment to have a 30amp. no im trying to figure out why it keeps shorting and were its doing it I thought it might have been from switching the lowbeam globes from 55w to 100w but they run on a different relay and even with the 55w back in same issue happens.
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 9:07 am 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

so does it 'pop' the fuse when the headlight switch is set to the parkers or does it only blow when all lights are on??

is there a problem with the switch itself? have you checked behind the fuse panel?

have you checked the wiring to the parkers front & rear? have you checked out the wiring in the boot & trailer wiring?


no idea on why a smaller amp fuse was thrown in
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 5:36 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

pops the moment lights are turned to parkers doesn't give it a chace to turn to lowbeam and yeah ive checks behind the fusebox and the wiring had to re solder the wire to the drivers side park light globe but that shouldn't cause this issue im stumped ive done all the usual checks and so on and everything seems fine but obviously there is a short somewere think I may have to take it to a auto elec Monday(tommorow)

as for trailer wiring I rewired a trailer plug a few weeks ago changed it from round to square but if it was that wouldn't this have happened a few weeks ago when I done the plug???
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 7:44 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

who knows what it could be

have you disconnected all lights from the wiring looms then plug them in one at a time?

are you able to disconnect the trailer wiring/plug so you can check?
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 10:48 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

yeah tested all the light one by one. il have to recheck the trailer plug tomorrow funny thing is I had to go out tonight so I needed the gauge lights, hoping it would work I took the fuse from ciggy lighter/radio port and plugged it into parker lights port and put the blown fuse in ciggy spot anyways for some reason radio still worked just had to be turned on/off manually when I start or stop car instead of turning on when car is on and off when car turned off is this usual??? anyways with no fuse in ciggy/radio port dash lights came on I turned parkers on/off about 10 times just to test and everything seemed good so I went off to do what I had to do and 3hrs later still works.

hhmmmm could this mean the leak is somewere around the ciggy port or even the ciggy port fuse spot? im happy for now but will most likely still take to auto elec just to be on the safe side
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 11:01 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

scithe93 wrote:
yeah tested all the light one by one. il have to recheck the trailer plug tomorrow funny thing is I had to go out tonight so I needed the gauge lights, hoping it would work I took the fuse from ciggy lighter/radio port and plugged it into parker lights port and put the blown fuse in ciggy spot anyways for some reason radio still worked just had to be turned on/off manually when I start or stop car instead of turning on when car is on and off when car turned off is this usual??? anyways with no fuse in ciggy/radio port dash lights came on I turned parkers on/off about 10 times just to test and everything seemed good so I went off to do what I had to do and 3hrs later still works.

hhmmmm could this mean the leak is somewere around the ciggy port or even the ciggy port fuse spot? im happy for now but will most likely still take to auto elec just to be on the safe side



well it gives you somewhere ta look/start aye! .. yeah take it to em as it can only help ya find the problem :lol:
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Sun Jul 20, 2014 11:19 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

scithe93 wrote:
could this mean the leak is somewere around the ciggy port

Sounds like it, cig lighter has a light nearby. The park light line is brown throughout the car, so shouldn't be difficult to find.
It's obviously shorting to earth - what you can do to isolate where the problem lies is to disconnect body loom plugs and see if the fault disappears - e.g. disconnect the connector behind the drivers kickpanel to isolate the rear of the car.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Mon Jul 21, 2014 4:24 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 18

Joined: 9th Jul 2014

Ride: ef falcon futura

Location: melbourne
VIC, Australia

went to the local auto elec this morning and now WALLAH problem solved there was a leak in the wire for the light that's in/near the ashtray no more dramas cost $140 though wish I could of fixed in myself for free haha

cheers for all the help guys
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Mon Jul 21, 2014 6:50 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

for $140 there BETTA be no more dramas aye! lol


snap told ya where the problem was :roll:
Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Mon Jul 21, 2014 7:11 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

^^^^ Yep, good call.
scithe93 wrote:
leak in the wire for the light that's in/near the ashtray no more dramas cost $140 though wish I could of fixed in myself for free

If you'd spent 10 mins checking it out . . . . . . . .

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: no dashlights/shifter lights & constant fuse blowing on a ef
Posted: Mon Jul 21, 2014 8:37 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Do wires leak :shock: !!!!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 16 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:23 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names