Fordmods Logo

Putting in New stereo in EL futura 1996 car now has no power 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Putting in New stereo in EL futura 1996 car now has no power
Posted: Tue Dec 04, 2012 6:27 pm 
Fordmods Newbie
Offline

Age: 49

Posts: 5

Joined: 2nd Dec 2012

Ride: Ford Falcon Futura EL 1996

Location: Canberra
ACT, Australia

Hi Took out olde stereo to put in new one . Lost all power no interior lights car wont kick over.
Keyless entry not working. Checked battery has power and alternator is fine. Any Suggestions would be appreciated. Thanks
Top
 Profile  
 
 
 Post subject: Re: Putting in New stereo in EL futura 1996 car now has no power
Posted: Tue Dec 04, 2012 6:35 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Check all blade fuses under the dash. The interior light fuse also is part of the smartlock system. Could be your cause. :idea:

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Putting in New stereo in EL futura 1996 car now has no power
Posted: Tue Dec 04, 2012 7:17 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Did you just use an aerpro adaptor harness for the stereo? Or you did the cut and shut on the factory plug?

You've blown a fuse or many sort it sounds... Visual check wont confirm a blown fuse... Use a test light and with key on check power to both sides of all the fuses in the dash...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: Putting in New stereo in EL futura 1996 car now has no power
Posted: Sun Jan 13, 2013 2:02 pm 
Fordmods Newbie
Offline

Age: 21

Posts: 9

Joined: 9th Jul 2012

Gallery: 1 images

Ride: Ford Falcon AU Series I

Location: Glenorchy
TAS, Australia

Weird. Check if the smartlock light illuminates, if it does then thats your trouble. not sure though, au owner and its different with it.

 

_________________

SIGNATURE REMOVED READ THE GUIDLINES. guidelines.php

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 3:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names