Fordmods Logo

Territory. Drivers window 'delay' in operating 


Page 1 of 1 [ 1 post ] 

 Post subject: Territory. Drivers window 'delay' in operating
Posted: Wed Jul 04, 2012 11:49 am 
Fordmods Newbie

Age: 60

Posts: 1

Joined: 4th Jul 2012

Ride: Ford Territory

Location: Auckland
New Zealand

Hi guys. Hope someone can help.
2006 territory Ghia. Drivers window sometimes won't respond to the switch to 'lower'.
Up to 2 minutes later, it may suddenly start, all by itself, like a delayed reacrtion, usually going fully 'auto down to bottom' mode.
The switch always raises the window ok.
An intermittent fault in lowering has now become a 'most of the time' problem.
Last time I measured the delay at 1 min 53 secs after pressing the button, the window suddenly worked.
Raised it, Pressed the down button, and waited 35 seconds for it to work.
Sometimes, after this it will work fine up and down, or not down at all, only comes up.

Have extracted but not dismantled the switch cluster, awaiting any guidance.
With that switch cluster priced at NZ$480 plus gst, would like to make sure it isn't a computer error or other that can be checked/corrected in diagnostics by the dealer.
Cheers, TonyO
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 29, 2016 1:38 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names