Fordmods Logo

Blown BEM!!?? 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Blown BEM!!??
Posted: Fri Mar 31, 2006 8:24 pm 
Getting Side Ways
Offline

Age: 30

Posts: 4609

Joined: 29th Jul 2005

Gallery: 10 images

Ride: BOXCAR

Location: Launceston
TAS, Australia

I am upgrading my BEM. I think I got a couple of the wires in the wrong pins. Anyway i fixed that but now, everything that is controlled by the BEM won't work (smartlock, power window relay, wipers, courtesy lights)

have i blown up my BEM? are there any internal fuses in it, i need help becuase now my car won't even turn over :cry:

 

_________________

^^^ What He Said

<a href="http://www.fordmods.com/forums/viewtopic.php?t=44952" target="_blank" class="postlink"> TAS Cruises</a>

Top
 Profile  
 
 
Posted: Sun Apr 02, 2006 10:36 pm 
Getting Side Ways
Offline

Age: 40

Posts: 2015

Joined: 9th Mar 2005

Gallery: 4 images

Ride: Territory TX AWD & AUII XLS EGAS

Location: East Kurrajong
NSW, Australia

Make sure it is earthed well ... I had that issue in my XG ute .... it immobilised the ute indefinitely .. that was fun.

 

_________________

04 Territory TX AWD - Winter White - optioned up
06 Falcon BFII XLS ute EGAS - Winter White - EGA-54D Version 2

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 7:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names