Fordmods Logo

dead regulator 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: dead regulator
Posted: Sun Jan 13, 2008 10:08 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

is there an easy way to find out how my regulator is doing? the voltage at startup is around 14.2v and drops slowly over 3-4mins to 13.2v. sometimes it goes as far down as 12.8v

and ive had the interior light blow recently too.

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
Posted: Sat Jan 26, 2008 8:58 am 
Parts Gopher
Offline

Posts: 81

Joined: 8th May 2007

Ride: NA Fairlane SVO

Location: Brisvegas
QLD, Australia

That sounds pretty normal to me. I think the standard constant voltage is around 13.8 so it seems that your battery is slightly low at the start, the load increases to increase the voltage to improve the charging and then it is back to normal. sounds normal to me but then again i am no autoelectrician.
Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 2:06 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

at times its been dropping to 12.5v when im on the brake peddle.

i think its related to heat. but im thinking it may be on the way out

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 11:20 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 520

Joined: 23rd Dec 2005

Ride: EF Futura Wagon

Location: Toowoomba
QLD, Australia

How are you reading the voltage? From the in dash diagnostics (EF/L) or in dash voltmeter (high series) or are you using an actual multimeter?

The reason I ask is because the in dash systems seem to read up to 1V low. Running the in dash diagnostics (you know press odo reset 3 times, hold till seat belt light goes out then release) I get a reading of 12.8-13.1 but using a multi I get 13.8.

cheers
Scott

 

_________________

If it doesn't fit, jam it. If that doesn't work use a hammer. - Engineers Motto

Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 3:57 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

My HU has a feature and the dash is near the same. i cant see both at the same time though.

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 4:11 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names