Fordmods Logo

Do ECU'S die??? 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Do ECU'S die???
Posted: Wed Dec 07, 2005 8:45 pm 
Parts Gopher
Offline

Age: 34

Posts: 62

Joined: 6th Oct 2005

Ride: ED Hwy rider

Location: Way out SE Melb
VIC, Australia

hey, got a ED I6, manual, with auto comp.
past few weeks, car has a mis fire in it, hot cold, wet dry, anytime doesn't matter, comes and goes like the wind, but it got worse,sounds like a WRX and got to the point you had to hold on to stop hitting the steering wheel it got that volient.
replaced plugs, leads, cap, rotor, injectors, haven't done compression test as nothing blows out of oil filler cap when removed.
so could the ecu have a problem and be playing up??? or any other idea's??

takes heaps

mark

 

_________________

5spd conversion, extac 2 1/2 mandrell bend, 2.92lsd, kings lowered.

Top
 Profile  
 
 
Posted: Wed Dec 07, 2005 8:58 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

have u changed coil? i notice its not on your list... also, blocked exhaust?
dodgy fuel? fuel filter? fuel pump? pressure reg?
get some1 to run the self test on the ECU. could also be the electronics in the dizzy itself...
Top
 Profile  
 
 
Posted: Wed Dec 07, 2005 9:53 pm 
Getting Side Ways
Offline

Age: 34

Posts: 419

Joined: 6th Nov 2004

Location: canberra
ACT, Australia

yes ecu can die usually there good, unless they get water in them, so maybe pull it out and have a smell and look at it.
also, it might be getting a dogy signal from crank, cam sensor, or air flow, although that usually wouldnt make it miss.
Top
 Profile  
 
 
Posted: Wed Dec 07, 2005 9:57 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 3097

Joined: 5th Nov 2004

Gallery: 29 images

Ride: VU SS

Location: Ivanhoe
NSW, Australia

Yes, they can die. Ages ago my car was running rich, and had a rough idle. Swapped in a different ECU and it was all fine. And no, it wasn't from being reset - that (and many other things) had been tried to resolve the issue.

 

_________________

EF Fairmont now Sold!
Guides: Polishing|Modifications |Manual Conversion

Top
 Profile  
 
 
Posted: Wed Dec 07, 2005 10:14 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

also could be the TPS switch giving the wrong signal to the ecu. my car had this problem

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Thu Dec 08, 2005 10:29 am 
Parts Gopher
Offline

Age: 34

Posts: 62

Joined: 6th Oct 2005

Ride: ED Hwy rider

Location: Way out SE Melb
VIC, Australia

ok, cool, thanks guys, give me a few other things to check, and more $$$ to spend,

thanks everyone

mark

 

_________________

5spd conversion, extac 2 1/2 mandrell bend, 2.92lsd, kings lowered.

Top
 Profile  
 
 
Posted: Thu Dec 08, 2005 6:21 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

if u really arent sure whats what itd probably be cheaper for u to pay some1 to diagnose it rather than just replace parts till u fix it..
Top
 Profile  
 
 
Posted: Thu Dec 08, 2005 9:50 pm 
Parts Gopher
Offline

Age: 34

Posts: 62

Joined: 6th Oct 2005

Ride: ED Hwy rider

Location: Way out SE Melb
VIC, Australia

yeah, it hasn't gotten to that point, everyone has said it's should have been fixed by replacing the leads, so it's goin to ford for a test, hopefully it's still doing it then.
thanks everyone for their help

mark

 

_________________

5spd conversion, extac 2 1/2 mandrell bend, 2.92lsd, kings lowered.

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 9:53 pm 
Parts Gopher
Offline

Age: 34

Posts: 62

Joined: 6th Oct 2005

Ride: ED Hwy rider

Location: Way out SE Melb
VIC, Australia

more so for ppl searching this problem,

the diagnostic test came back with nothing, basicly, nothing out of the ordinary.
problem in the end was one of the injectors was blocked open (yes on the second set) so it flooded the cylinder stopping the spark, but also lowering the pressure in the fuel rail enough to lean out the other cylinders. swapped the bad injector and she flys again now. 390 bucks for a $22 parts, doesn't it suck, hehe.

thanks for everyones help

 

_________________

5spd conversion, extac 2 1/2 mandrell bend, 2.92lsd, kings lowered.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names