Fordmods Logo

EF XR8 breaking down on petrol runs fine on gas 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: EF XR8 breaking down on petrol runs fine on gas
Posted: Sat Sep 27, 2008 3:46 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 81

Joined: 18th Apr 2008

Ride: ef xr8 xcop

Location: Mildura
VIC, Australia

My EF XR8 is breaking down really badly on petrol. When I boot it hard its like a rev limiter comes on (its an ex cop so theres no rev limiter) and it keeps breaking down until I back my foot off a fraction then it goes again......... But the car still runs fine on gas it actually feels like it goes harder on gas??????????

I have replaced the plugs, cap, button, ignition module, Fuel pump (drained petrol tank also) and fuel filter recently due to another problem(lucky I work at REPCO huh :lol: ) and I also had the timing done but when I got it back from the mechanic the breaking down is still there :(

Does anyone have any ideas? Would a dyno tune help or is it mechanical?

 

_________________

EF XR8 option 20 police interceptor :)

REPCO cars are our life too..........

Top
 Profile  
 
 
Posted: Sat Sep 27, 2008 8:20 pm 
Parts Gopher
Offline

Posts: 72

Joined: 13th Mar 2007

Location: Melbourne
VIC, Australia

Maybe time to get the injectors cleaned or get a reco set on ebay.
Top
 Profile  
 
 
Posted: Sat Sep 27, 2008 8:29 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

yeah sounds like your injectors have seen better days.

do you run it on gas more often than petrol?

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Sat Sep 27, 2008 10:52 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 81

Joined: 18th Apr 2008

Ride: ef xr8 xcop

Location: Mildura
VIC, Australia

alfy wrote:
yeah sounds like your injectors have seen better days.

do you run it on gas more often than petrol?


Ive only had it on the road for about 2 months in total but I usually run half a tank or so of petrol through it to every full tank of gas... but the fuel pump was on the way out when I got it and it has just been replaced so I guess the injectors could be dirty........

should I get standard ones again or is there a better option for a standard ex cop motor? like AU ones for example?

 

_________________

EF XR8 option 20 police interceptor :)

REPCO cars are our life too..........

Top
 Profile  
 
 
Posted: Sun Sep 28, 2008 12:35 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1037

Joined: 5th Nov 2004

Gallery: 1 images

Ride: V8 T5 Fairmont & BA XR6T

Location: Sydney
NSW, Australia

Is your MAF tripping a fault code? could be either the MAF has had it or the wiring has been damaged. I had a MAF go on me a couple of years ago.

 

_________________

Dima, Mitch & Jay's RPD

Top
 Profile  
 
 
Posted: Sun Sep 28, 2008 12:42 am 
Site Admin
Offline
User avatar

Age: 34

Posts: 8831

Joined: 18th Dec 2002

Gallery: 6 images

Ride: AUII V8 LTD

Power: 270 rwkw

Location: Sydney
NSW, Australia

I do about 500L of LPG to every 70L of Petrol and have never had any issues with the injectors. I know everyone says to do alot more driving on Petrol to keep the injectors in good shape, but I'm yet to see any issues. Maybe I'm lucky! I've done over 40,000KM this way in my LTD and did about 10,000KM in my Gha both without issue.

I realise this doesn't answer your original question, but you might save yourself alot of money on Petrol if you're only running (wasting!) that much for the purpose of keeping your injectors going. The savings from a few tanks of LPG will pay off an injector service even if I'm wrong ;)

 

_________________

WAG363: AUII LTD Supercharged 363 Dart Stroker [Supercharged 363 LTD Build]
WAGGIN: 2012 Volkswagen Passat Wagon - V6 4Motion.

Top
 Profile  
 
 
Posted: Sun Sep 28, 2008 1:42 am 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 81

Joined: 18th Apr 2008

Ride: ef xr8 xcop

Location: Mildura
VIC, Australia

Jaysen wrote:
Is your MAF tripping a fault code? could be either the MAF has had it or the wiring has been damaged. I had a MAF go on me a couple of years ago.


I dunno maybe I should get it to a mechanic to check for error codes?????

 

_________________

EF XR8 option 20 police interceptor :)

REPCO cars are our life too..........

Top
 Profile  
 
 
Posted: Sun Nov 23, 2008 12:00 pm 
Fordmods Newbie
Offline

Age: 54

Posts: 3

Joined: 17th Oct 2008

Ride: nl 5.0

Location: melbourne
VIC, Australia

Just disconnect your MAF and see what it runs like, it may run a bit better but not perfect,
Top
 Profile  
 
 
Posted: Tue Nov 25, 2008 7:42 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 81

Joined: 18th Apr 2008

Ride: ef xr8 xcop

Location: Mildura
VIC, Australia

I forget is the MAF the one on the intake or the one on the firewall????

 

_________________

EF XR8 option 20 police interceptor :)

REPCO cars are our life too..........

Top
 Profile  
 
 
Posted: Tue Jan 06, 2009 12:42 am 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 62

Joined: 31st Jul 2008

Location: Wodonga
VIC, Australia

preety sure its on the firewall mate

 

_________________

SWAP MY DL LTD V8 Sunroof Leather Sports Exhaust Gas Tint
FOR A SEDAN OR STATION WAGON 6

0413843332 Paul

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 5:31 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names