Fordmods Logo

EL running Funny 

 

Page 2 of 2 [ 29 posts ] Go to page Previous  1, 2

 
Posted: Sun Nov 04, 2007 11:44 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

Got the same prob on my hybrid EL. the problem has gone away for the most part but still hangs around a bit

i've noticed the engine shakes a bit at idle more than it used to. im thinking it might be more an induction problem as i have had the whole ignition sys replaced and a retime done twice.

either rockcover seal or intake manafold next i guess.

BTW a new battery seemed to help too?

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: EL Running Funny
Posted: Mon Nov 05, 2007 10:18 am 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Could the exhaust manifold gasket do it maybe?
Top
 Profile  
 
 
Posted: Mon Nov 05, 2007 4:34 pm 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

Yes if normall air is getting into the Manifold the engine will read massive Oxygen spikes and flood in fuel.
Then when it goes rich it will cut off fuel.
Top
 Profile  
 
 
 Post subject: EL Running Funny
Posted: Mon Nov 05, 2007 5:18 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Makes sense but wouldnt it happen on lpg also as it too uses oxy sensor?
Top
 Profile  
 
 
Posted: Mon Nov 05, 2007 5:42 pm 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

Yes it makes a big diffrence on IMPCO systems. IMPCO used a processor to regulate the lpg mixture it works on the same principles as fuel.
Top
 Profile  
 
 
Posted: Mon Nov 05, 2007 6:44 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

Was the timing set with the same procedure as a ED (Put in diagnostic mode then timing set straight after the idle goes up then down)? If so its wrong as on the EL you have to wait when in diagnostic about 2 min until the engine almost stalls then adjust the timing.
Top
 Profile  
 
 
Posted: Mon Nov 05, 2007 7:24 pm 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

EL ECU is hell Complicated
Get yaself a read of the EFI manual because there tottaly diffrent systems
EL is ECC-V
Top
 Profile  
 
 
 Post subject: EL Missing
Posted: Tue Nov 06, 2007 10:36 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Thanks garsiph and others, So car will run near perfect on lpg and half stuffed on fuel because oxygen sensor? Any other ideas? It used to run 100% power on Petrol and now it only does between 80-95 KPH. Its worst is off the line its dismal and the more you put it down the worse it is. If you baby it with little throttle it is perfect.
Top
 Profile  
 
 
Posted: Tue Nov 06, 2007 11:10 pm 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

It is a major contributing factor.
If the engine wont go over 100kmh its also in LHM
Top
 Profile  
 
 
 Post subject: EL running Funny
Posted: Wed Nov 07, 2007 5:19 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

It will go well over 100kph no problems at all but not with full acceleration unless running on lpg. Will try replacing sensor again. Cheers
Top
 Profile  
 
 
 Post subject: EL Running Funny
Posted: Wed Nov 14, 2007 10:47 am 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Oxy sensor made no difference at all. Any more ideas?
Top
 Profile  
 
 
Posted: Wed Nov 14, 2007 11:43 am 
Smokin em up
Offline

Age: 36

Posts: 210

Joined: 14th May 2005

Location: Perth
WA, Australia

Check out the ignition system
Top
 Profile  
 
 
 Post subject: EL Running Funny
Posted: Tue Nov 20, 2007 11:20 am 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

No Problems with ignition system any other ideas?
Top
 Profile  
 
 
Posted: Tue Dec 11, 2007 12:25 am 
Fordmods Newbie
Offline

Age: 41

Posts: 7

Joined: 3rd Apr 2007

Ride: ea ford fairmont

Location: millicent
SA, Australia

hay mate i dont know much about el's but on ea's when you do the timing there's a wire by the brake booster that you need to earth have you done that?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 29 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names