Fordmods Logo

Fordmods Advertising

help misfire 


Page 1 of 1 [ 3 posts ] 

 Post subject: help misfire
Posted: Thu Aug 30, 2007 6:47 pm 
Stock as a Rock
User avatar

Age: 33

Posts: 151

Joined: 4th May 2007

Ride: NL Fairlane

Location: Kwinana
WA, Australia

would a sticky injector cause rough and extremely rich running on an ed xr6,done a top rebuild,year old old fuel aswell.leads and plugs ok,any help appreciated,also blowin clouds of black smoke thgat stinks of fuel



NL fairlane soon to be blown :)

Posted: Fri Sep 07, 2007 9:39 pm 
Fordmods Newbie

Age: 29

Posts: 11

Joined: 13th Aug 2006

Ride: EL turbo

Location: Toowoomba
QLD, Australia

i would be thinkin more along the lines something to do with your map senser not working wether it be vac line disconnected or plug disconnected, i belive with ur o2 senser disconntected it will also run midly rich from memory but not 100% sure
Posted: Sun Sep 30, 2007 1:03 am 
Getting Side Ways

Posts: 647

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

did you say fuel was a year old?
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 10:40 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names