Fordmods Logo

Is my fuel pump dying? 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: Is my fuel pump dying?
Posted: Sun Jan 14, 2007 6:30 pm 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

ok sometimes just after i start the car it can be shudery when i go to slowly take off, and i when i boot it soemtimes really takes off and other times it doesnt seem like it has much power at all. or could it be the fuel reg? soemthing just doesn seem right. car has done 160,000k's.
Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 12:20 pm 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

thought one of you turbo guys would know about not enough fuel pressure or something
Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 12:26 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Maybe your cars just not happy at being kicked in the guts when cold?
I've yet to drive one that is...

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 12:34 pm 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

lol i dont kick it in the guts when itsa cold thats when i accerlate lightly and sometimes like once or twice every few weeks it seems to stutter. nut yes when driving around (warm engine) and i kick it the guts so to speak i fel real disapointed in the power then other times it takes off real well
Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 12:39 pm 
Technical Contributor
Offline
User avatar

Age: 33

Posts: 5858

Joined: 5th Nov 2004

Gallery: 8 images

Ride: '95 EF's

Location: Leederville
WA, Australia

can you hear it priming when you turn the key over first time?

 

_________________

R.I.P. Scotty

Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 1:57 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Is the pump whining or anything?
I've had two pumps die on me, both whined before kicking it.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 2:52 pm 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

did it show any other signs before it died like what i seem to be getting
Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 6:49 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

When my fuel pump was dying, i was getting the low fuel beeping from the warning buzzer, but there was a full tank of fuel in there. Then it just wouldn't start pumping fuel until you banged on the bottom of the tank.

You sure the problem is in the fuel system? Not in the ignition system?

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
Posted: Mon Jan 15, 2007 10:43 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 831

Joined: 9th Nov 2004

Gallery: 4 images

Ride: BA XR8 & 06 4x4 Bravo

Location: Pakenham
VIC, Australia

Fuel pumps normally just stop working.. When was the Fuel Filter last changed? Injectors blocked? Leads/Plugs?

 

_________________

Image
'04 BA XR8
Winter White, 5 Speed Manual, Sports Leather, Premium Sound, 2 1/2" Cat Back Exh - no rear Mufflers, Lowered SL/SSL, 20's, Underdrives, BF Typhoon Rear Spoiler, GT Steering Wheel, etc.

Top
 Profile  
 
 
Posted: Tue Jan 16, 2007 8:35 am 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

i changed the fuel filter about 20,000k ago, my ignition sysytem is ok the coil died and took out the hall affect sensor so i replaced all that, could it be my injectors cos a few of them are really loud compared to the others, they are still original and i doubt have bean cleaned
Top
 Profile  
 
 
Posted: Tue Jan 16, 2007 9:39 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 829

Joined: 5th Nov 2004

Ride: 2004 Mazda Tribute

dsheps83 wrote:
i changed the fuel filter about 20,000k ago, my ignition sysytem is ok the coil died and took out the hall affect sensor so i replaced all that, could it be my injectors cos a few of them are really loud compared to the others, they are still original and i doubt have bean cleaned


I would suggest getting the injectors checked. Also see if you can hear a whistling noise coming from the engine bay.

I have a leaking injector seal and am getting the same symptoms. that reminds me, I must get that fixed.
Top
 Profile  
 
 
Posted: Wed Jan 17, 2007 12:03 pm 
Oompa Loompa
Offline

Age: 51

Posts: 26

Joined: 17th Jan 2007

Location: newcastle
NSW, Australia

yes` finely someone who has the same problem as me!
I have gone through o2 sensors,cats,maf,mufflers,egr,pcv,fuel pumps,tried looking for vacume leaks,ground earth curcits,fuel injectors,had fault code checked (nothing there) gone through countless mechanics,a couple of grand & the problem is still there! I feel for you because I`m starting to loose it myself ,if you ever solve the problem can you let me know! because I`ll buy anyone a carton of beer if they can solve it

 

_________________

ON THE EIGHTH DAY GOD CREATED HOLDENS TO KEEP THE d***head OUT OF FORDS

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:49 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names