Fordmods Logo

Map sensor probs? 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Map sensor probs?
Posted: Fri Nov 07, 2008 2:50 pm 
Smokin em up
Offline

Age: 37

Posts: 262

Joined: 15th Aug 2007

Gallery: 3 images

Ride: Au fairmont seires I

Location: Sunshine coast
QLD, Australia

My car when it gets a little warm starts to tremble and splutter, it is an ef futura. Im goin to try the map sensor as i have done leads and spark plugs etc. Do i have to use a ef sensor or can i use a fairmont one or an el etc????? any better to use a higher model sensor? Im a little clueless of where it even is lol, someone help. Paul

 

_________________

People hate the au series but i wouldnt have it any other way!!!

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 3:43 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Does it tremble and splutter all the time or just under cruise and light throttle? I've just had similar problems and been losing the plot over it. My problem seems like it could be an engine coolant temp sensor. Maybe something else for you to look at.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 6:58 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1833

Joined: 3rd May 2007

Gallery: 8 images

Ride: AUII XR6 Uterus

Location: South Coast
NSW, Australia

i think (not an educated opinion lol) if it was the map sensor the problem would be full time.

mine does the same as scaffys but i have a new coolant temp sens.

wot seems to always work fine so i'm guessing its a sensor problem. 2 more sensors to go then the dizzy/tfi, it's doin my head in to.

 

_________________

Not to get technical, but according to chemistry alcohol is a solution.

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 7:17 pm 
Smokin em up
Offline

Age: 37

Posts: 262

Joined: 15th Aug 2007

Gallery: 3 images

Ride: Au fairmont seires I

Location: Sunshine coast
QLD, Australia

Scaffy wrote:
Does it tremble and splutter all the time or just under cruise and light throttle? I've just had similar problems and been losing the plot over it. My problem seems like it could be an engine coolant temp sensor. Maybe something else for you to look at.


i have lost cruise all together but thats another issue, lol. Its when i only touch the accelorator or when sitting at lights, But i went on a bug cruise up hills the other day and it worsened. so maybe it is a temp thing cause the car was pretty hot.

 

_________________

People hate the au series but i wouldnt have it any other way!!!

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 7:20 pm 
Smokin em up
Offline

Age: 37

Posts: 262

Joined: 15th Aug 2007

Gallery: 3 images

Ride: Au fairmont seires I

Location: Sunshine coast
QLD, Australia

OMG i wrote BUG Cruise lol wtf

 

_________________

People hate the au series but i wouldnt have it any other way!!!

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 8:03 pm 
Getting Side Ways
Offline

Age: 34

Posts: 756

Joined: 21st Nov 2005

Gallery: 25 images

Ride: 1999 AU futura

Location: griffith
NSW, Australia

Maybe have a look at your inlet gastket,make sure it isnt split or the bolts are done up.Check the fuel pressure make sure you dont a have an overfueling problem.see howya go.

 

_________________

COMING SOON,XD WITH A TURBO...CLEVO STYLE

Top
 Profile  
 
 
Posted: Fri Nov 07, 2008 8:24 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

If its under load the first thing to replace is the fuel filter, if no change it could be a head gasket.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:45 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names