Fordmods Logo

Power Lag Problem 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: Power Lag Problem
Posted: Fri Jul 01, 2005 4:04 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 1st Jul 2005

Location: Adelaide
SA, Australia

Hey guys!

haven't been here in a while it still looks as good as before!

I have an EF Fairmont ATM and it seems to have a problem, I seem to have a massive loss in power from 3000RPM to 4000RPM under full throttle. it does it exactly at this rev range not an RPM over or under it's really wierd got it serviced a week ago coz i tot it may be the plugs but it still does it? Could it be an electrical fault or something? I also think it may be the fuel pump cause the last one failed and i just got a new one in it. Hmm Quite an annoying problem

Any insights?
Top
 Profile  
 
 
Posted: Fri Jul 01, 2005 4:24 pm 
Site Admin
Offline
User avatar

Age: 34

Posts: 8831

Joined: 18th Dec 2002

Gallery: 6 images

Ride: AUII V8 LTD

Power: 270 rwkw

Location: Sydney
NSW, Australia

If power comes back on at over 4000rpm, then it isnt the fuel pump, it would have more problems supplying fuel high up in the rev range.

It may be MAF or TPS.. also check coils, leads and plugs.

 

_________________

WAG363: AUII LTD Supercharged 363 Dart Stroker [Supercharged 363 LTD Build]
WAGGIN: 2012 Volkswagen Passat Wagon - V6 4Motion.

Top
 Profile  
 
 
Posted: Sun Jul 03, 2005 3:57 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 1st Jul 2005

Location: Adelaide
SA, Australia

Thanx bud! Im not in with the jingo though whats MAF and TPS?
Top
 Profile  
 
 
Posted: Tue Jul 05, 2005 10:07 pm 
Oompa Loompa
Offline

Posts: 44

Joined: 24th Jun 2005

Location: Brisbane
QLD, Australia

tps = throttle position sensor, it's on the side of the throttle body.
maf I cant remember.
Top
 Profile  
 
 
Posted: Wed Jul 06, 2005 3:53 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

hey, i ve got the same f****** problem with my ef fairmont but mine happens between 2000 and 3000, but if i give it stick all of a sudden it comes back and kicks likes a b**ch. i have been told that my throttl body is f**k and it isn't opening at the right time, so i'm thinking of just getting a new throttle body, and i'll juts get a bigger one anyway.

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Wed Jul 06, 2005 4:00 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

Thanks for the swearing turbofairmont.....

Throttle body hs nothing to do with nothing other then a way to let air into the motor.

Your TPS, MAF (Mass Air Flow) meter or maybe even a worn throttle cable are more likely to be the problem

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Wed Jul 06, 2005 4:44 pm 
Getting Side Ways
Offline

Age: 31

Posts: 442

Joined: 7th Jan 2005

Gallery: 7 images

Ride: EF SERIES II FAIRMONT

Location: ADELAIDE, KLEMZIG
SA, Australia

yeah sorry about that. it just gives me the s**t, but anyway thanks for the info mate it will be very useful for me.

 

_________________

FORD 1996 EF FAIRMONT ARGON SILVER
18 INCH GT-P WHEELS
POWERCHIP,AWESOME STEREO,MONSTER FLOW POD FILTER
KYB LOWERED SHOCKs & KINGSPRING SUPERLOWS
XTRACTORS 2.5 INCH PIPES HI-FLOW CAT SML STRAIGHT THRU MUFF TWIN TIPS
DBA STREET SERIES SLOTTED ROTORS
*IT'S MY PRIDE & JOY*

Top
 Profile  
 
 
Posted: Wed Jul 06, 2005 6:51 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

I know what you mean, I tend to keep my language normal on the forums, but if you asked me about my car at times in person then alot if it would be quite colourfull .... hehehehehe

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
 Post subject: dead between 3000 and 4000
Posted: Sun Dec 04, 2005 5:46 am 
Fordmods Newbie
Offline

Posts: 2

Joined: 22nd May 2005

Location: Gauteng
NSW, Australia

:cry: Hi. I'm from South Africa. My Falcon is also dead from 3000rpm.
It happend after I send it in for a repair "a broken head bold". When I
took it back they could not find the problem. So now I'm also F.....*.
Top
 Profile  
 
 
Posted: Mon Dec 12, 2005 11:34 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 12th Dec 2005

Location: heathcote junction
VIC, Australia

i know what u mean with the power loss i have a simular problem with my EF fairmont 1995 from 0rpm two around 2500rpm its seem to be a bit laggy but once it gets two around 2500rpm i have full power the thing takes off and i have power until it hits the rev limiter. just been serviced new air filter fuel filter, throtal body clean. new plugs. i got no idea. i thought these parts might fix some problems but it hasnt. any clue's ta
Top
 Profile  
 
 
Posted: Tue Dec 13, 2005 10:55 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

i HAD this prob from the day i got my car and 2 weeks later fournd the problem, it would lag up to around 3 grand and then booom of you go, the car had just had the head done and it turned out the guy who did it put the vacume hoses for the bbm (intake manifold) on wrong,so it was stuck in high rpm mode. it took ford 20 mins to conferm and fix, apparently it is a common problem as people dont put the stuff back the same way it was found, or the vacume hoses get damaged.

just take it to a good ford dealer (pref 1 with a service dept bigger than the sales dept), i went to the one in niddrie (melb), and ask them to check your intake maifolds functionality. it cost me $40, i think it was well spent saved me many headaches.

hope it helps you guys.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Thu Dec 15, 2005 8:57 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

when you got it serviced did you tell them about the problem or ask them to fit or let you know what it was??

if you dont say any thing about it, it won't get fixed.

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
Posted: Thu Dec 15, 2005 10:35 pm 
Getting Side Ways
Offline

Age: 34

Posts: 419

Joined: 6th Nov 2004

Location: canberra
ACT, Australia

try a few things like one checking for air leaks in the manifold, cleaning out injectors, clean out throttle body, check exhaust isnt slightly blocked, also 02 sensor, and try resetting adaptions too. simple things alot of people miss or dont do.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 9:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names