Fordmods Logo

Problems with EL Tickford original dual-fuel, 

 

Page 2 of 2 [ 22 posts ] Go to page Previous  1, 2

 
Posted: Tue Nov 21, 2006 7:54 am 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

ELwagonTaxi wrote:
ok, where is this moving pin for injectors Im looking for? grounding and ungrounding moving or sliding pin, is it?
Moving pin? There are a few wires which runs from the LPG controller (called the AMS) and the engine ECU. One of which tells the ECC-V when it is on gas so the ECU can cut the injectors, remap the ignition timing and change the auto shift pattern. The others are for tach ect.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Tue Nov 21, 2006 9:09 am 
Oompa Loompa
Offline

Posts: 41

Joined: 20th Nov 2006

Location: keysborough
VIC, Australia

Reading all this....going out or calling out to see about getting a 2nd hand one of these things to try later.
Top
 Profile  
 
 
Posted: Tue Nov 21, 2006 9:25 am 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

You need to isolate the problem first, meter the line that tells the ECC-V to go to gas and make sure that the line is changing when changing from gas to petrol, if its not then the AMS side is faulty otherwise the ECU side is not working.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Tue Nov 21, 2006 10:27 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

twason wrote:
arm79 wrote:
The only difference between the ECU's is an injector shutoff pin which is controlled by the gas ECU, which in your case is under the seat. I thought they usually bolted them to the left side of the pedal box, unless I'm mistaken.

I am thinking that 6 seaters may need that area for the park brake so it may be reloacated under the seat. Thats where mine is heading when I go manual.


Ah yes... Should have realised when I saw the username. Even though a bench seat taxi is still a rare beast! :?
Top
 Profile  
 
 
Posted: Mon Nov 27, 2006 11:40 am 
Oompa Loompa
Offline

Posts: 41

Joined: 20th Nov 2006

Location: keysborough
VIC, Australia

the latest.
cAR IS now running sweetly on lpg youd never guess is any wrong with it. As of yesterday 5pm, with that tickford unit lid taken off it to oserve while i operated the dash fuel selector switch.

Car had blown a couple of fuses I noticed, but no way this was the original simple cause , as id checked them a couple of times while in the thick of it before. But noticing Id now lost ign spark as well, i went to fuses, and first one then another were gone, 1 30a 1 15a.. replced those, spark was restored, no start though, no response from LPG, wathing the exposed components inside the ECU make that buzzing sound as I tried to switch back and forth fuels, there are a line of 5 identical black bakelite electronic thingers adjacent to the largets of the loom sockets, the buzzing comes from one or all of them.

Anyway, suddenly there is a sharp snap! from the engine bay, and it leaps into life.
Ive seen it do that before, usually, it is stone dead again in the morning.
But this morning has started beautifully as well.

someone has told me this system always startscold on petrol anyway, evne when switched to LPG at a certain temperature...is this true?

anyway, although car is going like a bomb, youd back it to go to darwin and back if you didnt know what had been going on, im going to carry out other chores on it and keep searching for one of those units pictured..chances are still thats where its at, and Im sure ill be hearing from it again.
First attempt at FordSalvage Westall Rd Westall vic, i showed it to him,

oh, no, got none, Tickford LPG module, you'll be lucky to get one of those..

the bloke at the LPG conversion place says theyre plentiful, that they have thrown a box full of them away, having switched the cars to simplified LPG wiring..

So i have to ring more Ford wreckers, i guess...


Next issue.

Is it feasible to get the sump off an EL with engine in place?
serious oil leak from either front RH corner of sump, or else on TC near it, id hate to have to lift that friggen big 6cyl engine out just to do the gasket, but looks tough under there because of two crossmembers with suspension bars castor bar etc, on them..

Id like to thank everybody for their input, as although the battle with this LPG syustem isnt over, Im in better shape than i was a week ago, with everyones input..
Top
 Profile  
 
 
Posted: Thu Dec 21, 2006 6:50 am 
Oompa Loompa
Offline

Posts: 41

Joined: 20th Nov 2006

Location: keysborough
VIC, Australia

Persevering with this,with top off this LPG ecu, the buzzing comes from a line of 5 bakelite square whatevers adjacent to the 'General' port, anyway, by and by, car suddenly 'snapped' at the lock-offs and roared to life, while switched to lpg, and has started first turn since on gas, , but I dont think Ive heard the last of it, id still be scared to switch to petrol and then back to LPG, id say my troubles would be triggered again, good chance, so although im running, im still after a spare one of these particular ECUs pictured, as Id say its stuffing up in there when it feels temperamental,
then back again playing innocent when it pleases.. to cause more confusion.
Car back to together, seat back in, and now working on the oil leaks..

what happens next, Saturday afternoon, in supermarket carpark?

foot operated parking brake starts to malfunction..
wont ratchet and lock on..peddle just goes down and releases, without locking down and on first..
So now out it comes..
Top
 Profile  
 
 
Posted: Thu Dec 21, 2006 10:37 am 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

There is two fuses external to the AMS, one for ignition and one for battery. If these are the bakerlite boxes you are referring to then check and re-seat the fuses.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 22 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names