Fordmods Logo

Slow pick up/flat spot in EL I6. 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Slow pick up/flat spot in EL I6.
Posted: Fri Jun 09, 2006 8:14 pm 
Tyre Shredder
Offline
User avatar

Age: 41

Posts: 363

Joined: 23rd Sep 2005

Gallery: 1 images

Ride: XR6 Wagon

Location: Perth
WA, Australia

My mrs mate says her EL has a flat spot under acceleration. They have brand new plugs and leads. Could it be fuel pump or filter. Coil maybe, isc or oxygen sensor? Can anyone shed a bit of light on the subject? Should I do a Diagnostic check on it to eliminate some of the above items?

 

_________________

ImageImage
EF XR6 Wagon,RPD R6 cam,Wildcat extractors, Magnaflow cat,2.5" Lukey exhhaust.
Too many more too list

Top
 Profile  
 
 
Posted: Fri Jun 09, 2006 9:20 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4323

Joined: 17th Jan 2006

Ride: Soarer 2.5GT-T

Location: Cranbourne
VIC, Australia

If it feels like its running out of fuel, like jumping and such it's probably the fuel system... otherwise maybe throttle position sensor or something. <shrug>
Top
 Profile  
 
 
Posted: Fri Jun 09, 2006 9:48 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Dan......thats ur answer to everything :P hahahaha but yeah what ytmont said.....replace fuel filter and see how that goes. if it still persists try cleaning the TB.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 3:28 am 
Technical Contributor
Offline
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

how does it idle? no vacuum leaks?


Cheers

 

_________________

;++JustForDimSim++;

Cheap, fast and reliable.. choose 2.

Top
 Profile  
 
 
Posted: Sat Jun 10, 2006 1:08 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Ignition timing retarded.
Top
 Profile  
 
 
Posted: Mon Jun 12, 2006 2:38 pm 
Getting Side Ways
Offline

Age: 35

Posts: 1993

Joined: 5th Nov 2004

Ride: BA2 XR6T

Location: Mount Colah
NSW, Australia

it could be literally anything, i know that doesnt help, but its the truth !

 

_________________

BOOSTED

Top
 Profile  
 
 
Posted: Mon Jun 12, 2006 2:42 pm 
Getting Side Ways
Offline

Age: 31

Posts: 597

Joined: 19th Jun 2005

Gallery: 4 images

Ride: 98 XH XR6

Location: Diamond creek
VIC, Australia

check timing thats what my problem was

 

_________________

ONE FOR RUM AND RUM FOR ALL

4.0ltr 1998 XH XR6 - 2 JVC 4way 6X9's - 2 JVC 4way 4" in doors - JVC head unit - AU XR8 intake snorkel


Paceys, hi flow cat and many more still to come

Top
 Profile  
 
 
Posted: Tue Jun 13, 2006 2:02 am 
Tyre Shredder
Offline
User avatar

Age: 41

Posts: 363

Joined: 23rd Sep 2005

Gallery: 1 images

Ride: XR6 Wagon

Location: Perth
WA, Australia

Thanks for all the tips fellas. I asked them when the last time they had an injector clean. Turns out it had been quite a while, so they put in a cleaner/octane booster and it fixed the problem after about 100ks.

 

_________________

ImageImage
EF XR6 Wagon,RPD R6 cam,Wildcat extractors, Magnaflow cat,2.5" Lukey exhhaust.
Too many more too list

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 2:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names