Fordmods Logo

3.9L MPI...NO SPARK?!?!?!...Please help 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: 3.9L MPI...NO SPARK?!?!?!...Please help
Posted: Sun Jul 17, 2005 10:46 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

Last week coming home my EA 3.9 MPI just died, so we towed it home. Checking it out, I discovered the coil had split/cracked open, so we replaced it with one that was kicking around the shed. Still no go.
Checked power into coil (ok), checked power out (none). Put on a second coil from a running car. Still no go. Again checked power into coil (ok), checked power out (none).

Has this happened to anyone else?

Does anyone have ANY idea what to try next??? Could it be the TFI module? or the computer?

Any help would be greatly appreciated. Thanks.
Top
 Profile  
 
 
Posted: Sun Jul 17, 2005 11:14 pm 
Getting Side Ways
Offline

Age: 61

Posts: 437

Joined: 11th Nov 2004

Ride: EL GHIA

Location: adelaide
SA, Australia

TFI MODULE - common fault no spark
Top
 Profile  
 
 
Posted: Sun Jul 17, 2005 11:55 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

Is it as simple as changing the TFI or the whole dizzy?
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 12:06 am 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 744

Joined: 11th Nov 2004

Gallery: 15 images

Ride: ED Falcon

Location: Adelaide
SA, Australia

Or your coil lead is no good

 

_________________

I post here cos the russian tank driver doesn't

Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 12:15 am 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

opto wrote:
Or your coil lead is no good


Yup, checked that too...visual and ohms test. Both leads I have are ok.
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 12:17 am 
Getting Side Ways
Offline

Age: 61

Posts: 437

Joined: 11th Nov 2004

Ride: EL GHIA

Location: adelaide
SA, Australia

just the module but u have to take the dizzy out to fit

when mine went a***hole auto elec fitted so called recond dizzy and new tfi and charged me $350 and it run like a heap of crap

found out later dizzy they fitted was worn to the s**t and they broke #1 plug connection on a new set of 10mm leads i had just fitted and all it needed was the new TFI ~$90 part

moral - do the work yourself if ya can
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 12:25 am 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

tiny56 wrote:
moral - do the work yourself if ya can


I am.......but faaaaark me, what was Ford thinking when the put all the vital stuff under the intake manifold???? :x
Im gifted with a pair of "oars" for hands and it aint easy getting to the coil and leads :lol:

Anyway, all input is appreciated guys, Thanks!
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 12:36 am 
Getting Side Ways
Offline

Age: 61

Posts: 437

Joined: 11th Nov 2004

Ride: EL GHIA

Location: adelaide
SA, Australia

yeah its a pain

makes it a lot easier to get to if ya remove air box & throttle body
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:17 am 
Smokin em up
Offline
User avatar

Posts: 244

Joined: 6th Nov 2004

Ride: EA falcon

Location: Melbourne
VIC, Australia

I just had the exact same thing happen with my workhorse ED just a few days ago. What an absolute prick of a thing to get to! I'm going to be repositioning my coil somewere else in the engine bay so that next time it'll be a peice of piss to fix :) I suggest you do the same...
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:33 am 
Fordmods Newbie
Offline

Posts: 7

Joined: 17th Jul 2005

Location: mudgereebar
QLD, Australia

take the dizzy out and check the pick up inside for any wear marks or looseness of the shaft (side to side) if there are any marks on it replace the whole dizzy
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:13 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

There is a bit of movement in the shaft, how much is too much?
Im going to hunt down a longer coil lead, so I can move the coil to a more accessable area.
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:22 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

Is there any difference between a 3.9 MPI dizzy and a CPI dizzy?
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:40 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

sarcasticmrknowitall wrote:
Is there any difference between a 3.9 MPI dizzy and a CPI dizzy?


Yes the metal bit inside the dizzy that spins around the MPFI one has a vane thats different (smaller ot bigger can't recall), and thats to provide the PIP signal to the ECU for TDC of number 1.

Other then that they are 100% the same in all other aspects.

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 1:52 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

Dellboy999 wrote:
Yes the metal bit inside the dizzy that spins around the MPFI one has a vane thats different (smaller ot bigger can't recall), and thats to provide the PIP signal to the ECU for TDC of number 1.

Other then that they are 100% the same in all other aspects.


So I can swap that piece over and I can use a CPI dizzy?
Top
 Profile  
 
 
Posted: Mon Jul 18, 2005 9:06 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 98

Joined: 28th Mar 2005

Ride: 1996 DF LTD

Location: Country
WA, Australia

Anyone ever had probs getting the dizzy out? Both a mate and me had to use a pry bar to get it out (and yes we did take the retaining bolt out first), and now its as tight as to get it back in. Its stopped dead about 5mm before it should. Any thoughts on why???
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 12:39 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names