Fordmods Logo

4.0L slow to drop revs 

 

Page 2 of 2 [ 25 posts ] Go to page Previous  1, 2

 
Posted: Fri Apr 29, 2005 12:31 am 
Fordmods Newbie
Offline

Posts: 8

Joined: 26th Apr 2005

Location: Melbourne
VIC, Australia

Did the car idle high before you disconnected the ISC? Give it a bash with the handle of a screwdriver...they stick sometimes...just replace it don't leave it disconnected. It's there for a reason.

Also if the car is manual, check the switch behind the clutch pedal is engaging properly.
Top
 Profile  
 
 
Posted: Fri Apr 29, 2005 12:33 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 3097

Joined: 5th Nov 2004

Gallery: 29 images

Ride: VU SS

Location: Ivanhoe
NSW, Australia

So what's the go with this switch behind the clutch pedal.

Oh and I dont have my ISC connected either, car is much better without it.

 

_________________

EF Fairmont now Sold!
Guides: Polishing|Modifications |Manual Conversion

Top
 Profile  
 
 
Posted: Fri Apr 29, 2005 12:40 am 
Getting Side Ways
Offline
User avatar

Posts: 916

Joined: 27th Nov 2004

Gallery: 4 images

Ride: EL Futura

Location: Berri
SA, Australia

I dont think its a faulty isc thing, i believe its the way the ecu has been programmed.

 

_________________

5 Speed EL Futura
Stock as a rock*
Image
A1 Oils - Synthetic lubricants: www.a1oils.com.au
* A rock that has been Alted

Top
 Profile  
 
 
Posted: Fri Apr 29, 2005 2:57 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 927

Joined: 6th Nov 2004

Ride: BA Falcon EGas

Location: Perth
WA, Australia

hornet wrote:
I dont think its a faulty isc thing, i believe its the way the ecu has been programmed.


hornet's right, the stock ecu is meant to drop revs slowly. Just look at SVO XR6's that drops right away cause he has an aftermarket ecu (EMS).

 

_________________

BA Falcon Futura on EGas. Stock as...

EF 5 speed manual; PH 4480 Pacemaker Headers; 2 1/2" Lukey Mandrel Bent System; Hi Flow Walker Cat; Stage 3 Crow Cam; ChipTorque Chip; 3" Mandrel Bent Intake; K&N Pod Filter; Low Pedders Suspension; 17" EL GT Champagne Rims; RPM Series Clutch

Top
 Profile  
 
 
Posted: Fri Apr 29, 2005 5:29 pm 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

Smackdown wrote:
hornet wrote:
I dont think its a faulty isc thing, i believe its the way the ecu has been programmed.


hornet's right, the stock ecu is meant to drop revs slowly. Just look at SVO XR6's that drops right away cause he has an aftermarket ecu (EMS).



The stock ECU prolly drops slowly for some s**t reason like emission control.

I guess one fix for crook idle at first startup when the ISC is disconnected is to run a wire to a switch so you can activate/deactivate it when you want - use the switch like a choke when the engine's cold (I realise it won't do the same thing as a choke - I mean it'll have the same result - ie. make the engine idle up and cope better when cold).

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
 
Posted: Sat Apr 30, 2005 10:56 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

mine has this problem also, it can be a pain in the a*** to drive.

Also when you're driving along, and pull it out of gear (neutral) it'll sit
around 1300 rpm for a few seconds before dropping to idle rpm.
It will also do this if i come to a stop.

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
Posted: Sun May 01, 2005 6:21 am 
Oompa Loompa
Offline

Age: 35

Posts: 36

Joined: 15th Mar 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

got sick of the damn thing yesterday, so i disconnected the ISC and adjusted the idle speed and so far no probs. it doesnt like cold mornings as expected, but after about 30 seconds its fine. looking at getting an aftermarket ecu so wont stay like this for too much longer i hope

 

_________________

those who live by the sword get shot by those who dont

Top
 Profile  
 
 
Posted: Sun May 01, 2005 2:06 pm 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

smoke_rubber wrote:
mine has this problem also, it can be a pain in the a*** to drive.

Also when you're driving along, and pull it out of gear (neutral) it'll sit
around 1300 rpm for a few seconds before dropping to idle rpm.
It will also do this if i come to a stop.


Is yours a factory manual or converted?

Asking cause I've just done the conversion and have the same exact problem - tho I've retained the Auto ECU and haven't fitted the resistors yet for tricking the ECU about Auto trans temp and gear selection (they may be here in a few days - joys of living in s**t holes ville WA - not for long tho!)

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
 
Posted: Sun May 01, 2005 8:17 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

mine is a factory manual

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
Posted: Sun May 01, 2005 8:25 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Hmm mine used to do this when i reved it or someting in park or neutral, it would take a while for it to rev down... Never really bothered me, and never noticed it while driving.

Since the new exhaust i noticed it doesnt really do it ne more either, it pretty much drops straight down when you rev it now... :?

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 25 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:12 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names