Fordmods Logo

94 Futura 4.0L OHC, WONT REV OUT!! 

 

Page 1 of 3 [ 34 posts ] Go to page 1, 2, 3  Next

 
 Post subject: 94 Futura 4.0L OHC, WONT REV OUT!!
Posted: Sun Apr 27, 2008 2:39 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

hi every1..

i have this problem thats realy pissing me off! mad.gif

i have a 94 futura 4L OHC manual and i have put a new water pump, alternater, blets, and spark plugs and it will not rev out past 3500rpm... ive been around the whole motor looking 4 lose wires and everything an i cant find anything that could be making it do this!

it bounces like it would do if it would rev al the way out. sort like a valve bounce... gunvera.. rev cut

its like its in (LIMP) mode or something

I don't know if this would mater? but the temp gauge is not working and the temp light stays on in the dash and theres no thermostat..

can any1 please help??

thanks
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 2:46 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2754

Joined: 14th Apr 2005

Ride: fairmont

Location: mackay
QLD, Australia

hows ur muffler box????

in my ED it wouldnt rev past 3000rpm due to a big crack the whole length of the muffler box

 

_________________

Now i have a EF XR8 5spd.........mmmmmm 5L

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 2:57 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1798

Joined: 14th Jun 2006

Gallery: 7 images

Ride: FG 50th Anni G6E Turbo

Location: Melbourne
VIC, Australia

Also, could be a blocked Cat?
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 3:07 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

it never use to do this an it runs smooth and idles sweet doesn't sound like it has a blocked muffla i mite just drop the exuast off and see it changes anything.

but it dosent rev to 3500 and stop. It revs to it and bounces like its hiting the rev cut..

also if i hold my foot flat to the floor and start it up it revs 2 6000 for a sec then dies back down to 3500..
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 6:50 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

blocked cat mate definitely

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 6:50 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

double post

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 7:46 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

try reseting your computer

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 8:00 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

SgtBourne wrote:
blocked cat mate definitely


ok ill take it off an try it lol
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 8:00 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

ea_falcon wrote:
try reseting your computer


nope that didnt work at all tryed it a few times
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 9:02 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

did you disconnect the battery for at least 30 minutes?

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 9:03 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

also make sure you flick your lights on and off a couple of times when u disconnect the battery to drain the system fully
but like the other guys said its most probably a blocked cat but its worth a try

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 9:17 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

change the fuel filter if that doesnt fix it then try the fuel pump, had a similar problem with a mates car the other day, i changed the fuel pump and problem solved..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 10:25 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

cool thanks ill try all of those things and get back 2 youz
Top
 Profile  
 
 
Posted: Sun Apr 27, 2008 11:46 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

You should also consider swapping in a known to work Map sensor.

That could be the problem too.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 11:08 am 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

BenJ wrote:
You should also consider swapping in a known to work Map sensor.

That could be the problem too.

BenJ



Were would i find the map sensor?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 3  [ 34 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 7:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names