Fordmods Logo

95 EF GLi New TPS, Auto Trans wont change properly :( 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: 95 EF GLi New TPS, Auto Trans wont change properly :(
Posted: Wed May 18, 2011 6:56 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 14

Joined: 8th May 2010

Gallery: 1 images

Ride: 1995 EF Falcon Wagon

Location: Eumundi
QLD, Australia

Hey all. I have a 1995 EF Gli Automatic 4 litre Wagon. I have I have just installed a new TPS cause the old one was F*****. even with the dead one the Auto Trans changed gears perfectly smooth on up and down shifts even when pulled down gears manually but now it holds the rivs up really high before changing and wont go into 4th gear at 60k's in power mode like it used to, it reaches 4th gear at about 95km now. please help ASAP :)
Top
 Profile  
 
 
 Post subject: Re: 95 EF GLi New TPS, Auto Trans wont change properly :(
Posted: Wed May 18, 2011 7:21 pm 
Tyre Shredder
Offline
User avatar

Age: 42

Posts: 368

Joined: 22nd Aug 2008

Ride: 2002 AUII Fairlane Sportsman V8

Location: Roxby Downs
SA, Australia

I am no expert on TPS module's however i have been told that they might need adjusting somehow once/before you install them.

My mechanic said best go & get a complete used throttle body & install it. That way you don't have to muck around with adjusting etc.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:49 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names