Fordmods Logo

96 EL Ghia Ignition Coil Dramas 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: 96 EL Ghia Ignition Coil Dramas
Posted: Mon Feb 22, 2010 11:27 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 22nd Feb 2010

Ride: EL Ghia

Location: Mel
VIC, Australia

Hi all,

Been reading through this site and like it a lot.
My ghia has gone through 3 ignition coils in the last 12 months
they fail with no warning or hint of engine trouble. It just stops and there's no spark at all.
I've replaced leads, distributor, rotor button, distributor cap and again the coil went after a couple of months.
I've just fitted a new one and away she went.
Anyone else had similar problems?
Until now I've had no trouble with the car at all.
Also I discovered if the cruise will not turn on check the brake lights. no brake lights also = no cruise!
One dodgy fuse later fixed the brake lights and the cruise.

cheers
Stu
Top
 Profile  
 
 
 Post subject: Re: 96 EL Ghia Ignition Coil Dramas
Posted: Tue Feb 23, 2010 3:14 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Are you using Bosch coils???....are they being mounted correctly???.....may have to look at moving it.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: 96 EL Ghia Ignition Coil Dramas
Posted: Tue Feb 23, 2010 1:45 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 22nd Feb 2010

Ride: EL Ghia

Location: Mel
VIC, Australia

cjh wrote:
Are you using Bosch coils???....are they being mounted correctly???.....may have to look at moving it.


The first two were genuine parts.
The second one is a Bosch not sure about the first one (never saw it)
The third and current one is a Bosch from Repco.
As far as I can tell they have been mounted correctly I unbolted the second one, attached the brackets to the new one and bolted the new coil and the supressor in place.
The new coil is different to the last one in that the king lead connector and the vehicle wiring loom connector are both on the same end of the coil. According to Bosch it is a replacement for the other one which has the king lead connector and the wiring loom plug on opposite ends.
The new one includes a short extension lead as the vehicle wiring loom does not reach the front of the new coil.

cheers

Stu
Top
 Profile  
 
 
 Post subject: Re: 96 EL Ghia Ignition Coil Dramas
Posted: Wed Feb 24, 2010 3:52 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Something wired going on there. You dont wash the engine much do you? The new bosch coils are lighter and meant to be better than the old ones. Still got the original coil in my Ghia. I have gone through a dizzy.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 5:24 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names