Fordmods Logo

A list of problems I need fixed! 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 1:10 am 
Parts Gopher
Offline
User avatar

Age: 28

Posts: 80

Joined: 20th May 2012

Ride: 90' Ford Fairlane SVO

So fella's, I have a list of things wrong with my car as followed, but I can't afford to take my car to repair them, nor do I want to sell. I'm just hoping I'll be able to fix them myself. Car is an NA Fairlane. Here is the list:

My biggest problem is when the car is cold, it idles very roughly, even when I take off, it's still very rough and the power is laggy as hell. This lasts for the first few k's, then seems to almost go completely, only when taking off again, it can lag a little still. Any ideas what this could be?

Fuel usage. Going by the trip computer (which I know to be true as I've tested it), I seem to be burning through a quarter to half a tank more than I should be.

Electrics! They're all over that shop!
My outta door keyhole lights stay on permanently
My interior lights don't work at all
My dash lights will sometimes go
My electric windows will sometimes not work
And my head unit doesn't work (factory)
All were fine a little more than a year ago.
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 10:01 am 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

so ya got a problem with ya electrics....

check all wiring & relays in ya engine bay 1st
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 10:31 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

Do you have a circuit and a multimeter ? Or a friend that know electrics ? Most are probably unrelated, so start working on 1 at a time. If you have a MAP sensor, it may be worth checking for the idle and fuel issues. Make sure all the electrical plugs are secure, and pull them away slightly and push them back on firmly. In time the contacts get a slight oxide coating, and doing this will " clean " them. In IT this is known as a reseat, and is why when you swap in a part it works, then you try the old one again and it works. All the " Bells and whistles " are great with a new car and they all work, but can be troublesome as the car ages. If you are near the coast the salty air will add to your issues. Good luck with it.

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 10:59 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

I'll try to help with a few of these:

My biggest problem is when the car is cold, it idles very roughly, even when I take off, it's still very rough and the power is laggy as hell. This lasts for the first few k's, then seems to almost go completely, only when taking off again, it can lag a little still. Any ideas what this could be?

Fuel usage. Going by the trip computer (which I know to be true as I've tested it), I seem to be burning through a quarter to half a tank more than I should be.


For both of these, I'd start with a good service and tuneup and go through the basics; air filter, spark plugs, leads, dissy cap and rotor. I'd also be checking for any loose vacuumn hoses, particularlly around the MAP sensor. It'd also be wise to clean the throttle body and intake tubing. a new Fuel filter wont hurt eithier.

Electrics! They're all over that shop!

My outta door keyhole lights stay on permanently
Check for a bad earth somewhere, both inside the door near the light, and around the battery, make sure all the connections are clean and tight. a light being on permanantly will cause your battery to die quickly also

My interior lights don't work at all
Could be a bad fuse, or maybe ALL the bulbs are blown (Unlikely)

My dash lights will sometimes go
Most likely a bad earth or a loose connection somewhere. Check all the earths, and make sure the cluster is firmly plugged in.

My electric windows will sometimes not work
Generally what happens with these if it is an intermittant fault is the switch cluster plays up. It can sometimes be taken apart and cleaned out with contact cleaner, or you can just replace it. They aren't dear

And my head unit doesn't work (factory)
Again, it could be the fuse. Always remember though if a fuse has blown, it's generally blown for a reason, they can blow just from being 20 years old, but generally they blow for a reason. This could very well be related to why your interior lights don't work, because I think they both run off the "CLK/CRT LMP" fuse. I'd start by replacing that fuse, and see if it blows again.
All were fine a little more than a year ago.[/quote]

Hope this helps, Gab
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 7:01 pm 
Parts Gopher
Offline
User avatar

Age: 28

Posts: 80

Joined: 20th May 2012

Ride: 90' Ford Fairlane SVO

Thanks heaps fella's! :D
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 8:26 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1273

Joined: 30th Sep 2007

Ride: g6e 2009

Location: hiding in the bushes
WA, Australia

the power issue from cold and take off sounds to me like a dirty fuel filter, or a dodgy fuel pump.
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Tue Aug 13, 2013 8:27 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1273

Joined: 30th Sep 2007

Ride: g6e 2009

Location: hiding in the bushes
WA, Australia

failing that i would also be changing the ht leads
Top
 Profile  
 
 
 Post subject: Re: A list of problems I need fixed!
Posted: Wed Aug 14, 2013 8:07 pm 
Stock as a Rock
Offline
User avatar

Age: 30

Posts: 109

Joined: 17th Feb 2009

Ride: NF Fairlane Ghia

Location: Crestmead, Brisbane South
QLD, Australia

Your car hesitating for the first few moments sounds a lot like an issue this guy had:
ford-4l-and-6-cylinder-f1/car-hesitates-t118315-30.html

Coincidentally also something iv been experiencing, Although iv yet to get it sorted. I'm giving mine to a mechanic tomorrow to go nuts.. It's got way to many issues for my liking.

So yeah.. i agree with distributor & coil change. The other issues i wouldn't have a clue.. Sounds like you got many electrical faults to start finding. Multimeter is looking like a worthwhile purchase.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names