Fordmods Logo

AC causes noxious gas in cabin ? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: AC causes noxious gas in cabin ?
Posted: Sat Dec 09, 2006 1:57 pm 
Parts Gopher
Offline

Posts: 87

Joined: 3rd Sep 2005

Gallery: 3 images

Ride: EL Fairmont

Location: Melbourne
VIC, Australia

Hi Folks,

I've noticed that when I run the AC I get a noxious funes inside the cabin, I'm not sure if its like a leaking AC gas or an exhaust fume-type smell.

It is only really noticeable when I'm sitting still at the traffic lights and stuff, when I'm cruizing on the freeway, it seems to clear up.

I've also tried setting it to re-circulate and fresh ait setting, but it doesnt make any difference to the gas smell.

Any ideas what it might be ? could it simply be incorrect vaccume plumbing ?
Top
 Profile  
 
 
Posted: Sat Dec 09, 2006 2:23 pm 
Technical Contributor
Offline
User avatar

Posts: 691

Joined: 1st Jun 2005

Ride: EFII Sedan

Location: Brisbane
QLD, Australia

I had a strange metalic smell like that after I installed the new evaporator/condenser core in the dash in the EB. I first thought it was gas escaping too, but the smell disappeared after a while, which led me to believe it was just the new metal venting whatever it was made with during manufacture. It stopped after wa whuile, and the ac still worked super cool, so I don't think it was refrigerant.

Get it sniffed out by an AC place.

 

_________________

EF II Sedan
Ex Chaser, Dual Fuel (Impco LPG)
LSD High, 3.23, Black wheels, other shiny bits.

EB II Sedan <--- R.I.P. (Rest in pieces - gone to the wreckers for $50...... bargain!)

Top
 Profile  
 
 
Posted: Sat Dec 09, 2006 4:37 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1181

Joined: 13th Dec 2005

Gallery: 3 images

Ride: 98 Patrol

Location: Maryborough
QLD, Australia

How often do u use AC? cause i had a smell after i didnt use it for 4 months...
Its gone now...

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Dec 11, 2006 7:53 pm 
Parts Gopher
Offline

Posts: 87

Joined: 3rd Sep 2005

Gallery: 3 images

Ride: EL Fairmont

Location: Melbourne
VIC, Australia

I've been using it on/off for the last 3 weeks or so, and its still doing it, I contemplated that it might just be exhaust gas from other traffic <sbhrug>.

At any rate, the system is stock-standard and the AC has never been serviced, so I might drop it in somewhere when I get a chance and let the experts figure it out. :)

Dont suppose anyone could reccomend anywhere ?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google [Bot], tidy au and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:04 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names