Fordmods Logo

alternator flashes, trip computer beeps warning 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: alternator flashes, trip computer beeps warning
Posted: Mon Jul 25, 2005 11:05 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

hey everyone

when i start my car the engine turns over, but the battery light flashes and trip computer beeps. im guessing alternator isn't turning. but when i rev my car a bit to about 1500 or 2000rpm the light turns off, beeping stops.

anyone know whats causing this? could it be slipping?

cheers

phong

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Mon Jul 25, 2005 11:17 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 850

Joined: 10th Nov 2004

Gallery: 20 images

Ride: 03 BA Fairmont

Location: Forest Lake
QLD, Australia

mine is curently doing the same thing. The problem is with the regulator on the alternator. It is an easy replace job, but you might consider replacing / refurbishing the unit.
in my case the cause is the power steering pump leaking oil all through the alternator which is directly above it. check to see if this is the case with your vehicle and of cause, repair that problem before seeing to the alt.

 

_________________

Regards,
Punnisher_42
_____________
2003 BA Fairmont - Stock standard
1994 U13 cough Nissan Cough Bluebird

Favorite Quotes:
"Sportwagon = homo-erotic wank-fest." - downingj

Top
 Profile  
 
 
Posted: Tue Jul 26, 2005 3:49 am 
Getting Side Ways
Offline

Age: 31

Posts: 3893

Joined: 15th Nov 2004

Gallery: 24 images

Ride: BF MKII V8 Fairmont Ghia

Location: Perth
WA, Australia

why did ford find it as a good idea to put the alternator on the bottom of the engine for the |6? always seems to have s**t dripping on it from above and puddles gettin it from below :?

 

_________________

2007 Steel BF Ghia MKII V8 - 19" GTP's + Superlows

Top
 Profile  
 
 
Posted: Tue Jul 26, 2005 9:01 pm 
Getting Side Ways
Offline

Age: 40

Posts: 2015

Joined: 9th Mar 2005

Gallery: 4 images

Ride: Territory TX AWD & AUII XLS EGAS

Location: East Kurrajong
NSW, Australia

Punnisher_42 wrote:
mine is curently doing the same thing. The problem is with the regulator on the alternator. It is an easy replace job, but you might consider replacing / refurbishing the unit.
in my case the cause is the power steering pump leaking oil all through the alternator which is directly above it. check to see if this is the case with your vehicle and of cause, repair that problem before seeing to the alt.


Hello ... I have the same issue.
power steer pump is apparently a f**k expensive part too. I have it leaking out of the pipe at the rear of the pump ... might see if good old plumbers tape will hold it bay for a short while.

It's only dripping occasionally ... did a degreaser to check ... it's dripping straight onto the alternator ... and I get the odd time the battery light comes on ... goes after a rev. The alternator gets full of p/s fluid and stuffs it up.

 

_________________

04 Territory TX AWD - Winter White - optioned up
06 Falcon BFII XLS ute EGAS - Winter White - EGA-54D Version 2

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 3:42 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names