Fordmods Logo

AU Brake lights 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: AU Brake lights
Posted: Sat Sep 24, 2011 3:18 pm 
Smokin em up
Offline

Age: 27

Posts: 214

Joined: 19th Jul 2009

Ride: Ford EL Fairmont Ghia

Location: Melbourne
VIC, Australia

Hey guys, a mate just told me his 3 rear brake lights all went out, im guessing this is a blown fuse but he said the fuse looks in tact. Is there anything else that could cause the brake lights to fail (apart from blown bulbs) ?

Thanks guys
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Sat Sep 24, 2011 3:36 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Check the brake switch on the actual brake pedal, these are known to fail as well.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Mon Sep 26, 2011 3:00 pm 
Smokin em up
Offline

Age: 27

Posts: 214

Joined: 19th Jul 2009

Ride: Ford EL Fairmont Ghia

Location: Melbourne
VIC, Australia

thanks mate, and how do i check that? Sorry if thats a dumb question lol, but never checked it b4
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Mon Sep 26, 2011 5:19 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

Nathanhrv wrote:
thanks mate, and how do i check that? Sorry if thats a dumb question lol, but never checked it b4

power in -switch-power out to lights-test light,press the pedal to complete the circuit,power both sides,if not-a new one.

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Tue Sep 27, 2011 10:20 am 
Smokin em up
Offline

Age: 27

Posts: 214

Joined: 19th Jul 2009

Ride: Ford EL Fairmont Ghia

Location: Melbourne
VIC, Australia

Ok so ive diagnosed it that the brake switch is the problem however its not stuffed just loose. I had a fiddle with it while it was still connected and when i tilted it upwards the brake lights switched on, however when i put it back down the brakes went back off. i was gonna use a ziptie to hold it in the upright position however from the fiddling i think i blew the fuse as it stopped turning on when i tilted it up. i called it a day/night as i couldnt see sh*t haha so im gonna have another crack 2day

anyone got any ideas or tips? and also if my mate were to buy a new brake switch would this fix the looseness problem or is this an issue with where it mounts?

Thanks guys
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Tue Sep 27, 2011 10:28 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

the brake light switch is stuffed, we had the same issue in our au, you could move it to get it to work then after a couple of times on and off the brakes it would stop again..
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Tue Sep 27, 2011 10:30 am 
Smokin em up
Offline

Age: 27

Posts: 214

Joined: 19th Jul 2009

Ride: Ford EL Fairmont Ghia

Location: Melbourne
VIC, Australia

oh ok thanks troyman so getting a new one is the way to go?

Also any tips on removing and reinstalling?

Thanks mate
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Thu Sep 29, 2011 4:50 am 
Parts Gopher
Offline

Age: 53

Posts: 99

Joined: 6th Sep 2010

Ride: 1997 el ford

Location: pearcedale
VIC, Australia

get youre head under dash disconnect plug then pull out clip should be yellow watch out for plastic spacers they might drop pull out the pin then the switch should slide off to the left replace is the reversal hope this helps
Top
 Profile  
 
 
 Post subject: Re: AU Brake lights
Posted: Fri Oct 07, 2011 7:25 pm 
Smokin em up
Offline

Age: 27

Posts: 214

Joined: 19th Jul 2009

Ride: Ford EL Fairmont Ghia

Location: Melbourne
VIC, Australia

hey guys all fixed now thanks for the tips, the switch was rooted and then i had to resolder one of the wires which became detached on the mount for the brake switch but all working now, thanks again
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 8:35 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names