Fordmods Logo

AU Fairlane - backfired on lpg now idles way to high 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: AU Fairlane - backfired on lpg now idles way to high
Posted: Mon Nov 30, 2009 8:23 am 
Fordmods Newbie
Offline

Age: 41

Posts: 5

Joined: 30th Nov 2009

Ride: AU Fairlane

Location: Napier
New Zealand

Hi guys, great forums. I just signed up.

I have a 1999 AU Fairlane VCT.

Previously running perfectly on petrol.

The LPG just started playing up, and I got a decent backfire underthe bonnet yesterday.

When I switched to petrol, the engine idles at around 3000 rpm, and requires constant braking to maintain speed down to 50 or 100 kmh.

I think my front pads are toast as I was 500 kilometres from home when this happened lol.

Fuel economy doesnt seem to have changed, but smells like its running rich, idles instantly around 3000rpm, consequently a big thump shifting into Drive, and wants to creep up speed without any accelerator pressure while driving.

Was idling perfectly before the backfire. Now with the 3000 rpm idle, shift into drive with foot on the brake, engine speed drops to 1400 or so, but she is straining to get off the line!

Otherwise, engine running smooth as, and no problem.

Any clues on where to start?

Has something common potentially happened? A MAP or MAF sensor been hurt by the bang? killed a hose or seal somewhere?

The problem all but goes away back on LGP, but at anything other than maintaining cruising, its f@rt/popping/backfiring while on LPG.

Cheers in advance for any help you can offer.

Tony
Hawkes Bay, New Zealand
Top
 Profile  
 
 
 Post subject: Re: AU Fairlane - backfired on lpg now idles way to high
Posted: Mon Nov 30, 2009 8:34 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

a vacuum line has come off somewhere.
listen for a hissing in the engine bay, should be pretty easy to find.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
 Post subject: Re: AU Fairlane - backfired on lpg now idles way to high
Posted: Mon Nov 30, 2009 8:36 am 
Fordmods Newbie
Offline

Age: 41

Posts: 5

Joined: 30th Nov 2009

Ride: AU Fairlane

Location: Napier
New Zealand

EFFalcon wrote:
a vacuum line has come off somewhere.
listen for a hissing in the engine bay, should be pretty easy to find.

THANKS!!

Yes, I did hear a significant hissing.

Will go home soon and check it out!

Probably save me many $$ putting it into the workshop.

I can do basic tasks, but my faultfinding is not up to par!

Cheers EFFalcon.

BigT
Top
 Profile  
 
 
 Post subject: Re: AU Fairlane - backfired on lpg now idles way to high
Posted: Tue Dec 01, 2009 9:04 am 
Fordmods Newbie
Offline

Age: 41

Posts: 5

Joined: 30th Nov 2009

Ride: AU Fairlane

Location: Napier
New Zealand

D'oh...

Couldnt find a line off anywhere, so drove to my mechanic friends workshop to get him to look.

He instantly pointed out the 1 inch piece of intake manifold gasket that was missing.

Replaced now!

Pity it wasnt a hose ($free) vs. gasket ($100 incl labour).

Thanks for the help anyway!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: mav666 and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 1:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names