Fordmods Logo

Fordmods Advertising

AU II I6 Heater problems 


Page 1 of 1 [ 2 posts ] 

 Post subject: AU II I6 Heater problems
Posted: Sun Aug 31, 2008 10:13 pm 
Stock as a Rock

Age: 36

Posts: 117

Joined: 3rd May 2006

Location: melbourne
VIC, Australia

Hi Guys ,

I have just bought a AU II Futura I6 Auto with 110 klm , the heater does not warm up when turned on and has been picked for (rwc) , it is also running fairly rich.

on advice i have just changed the thermostat which has slighly improved the running of the car however the heater is still not working .

Any suggestions guys ? would be a great help .

Posted: Mon Sep 01, 2008 11:37 am 
Getting Side Ways

Age: 60

Posts: 437

Joined: 11th Nov 2004


Location: adelaide
SA, Australia

well the obvious place to start may be the heater tap and if its got climate control check the vacumm lines or blocked heater core

and running rich - is the car getting to correct operating temperature if not that could be both ur problems - new thermostat @ 92'
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 8:07 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names