Fordmods Logo

ba-bf falcon engine probs 

 

Page 4 of 4 [ 50 posts ] Go to page Previous  1, 2, 3, 4

 
Posted: Tue Feb 28, 2006 3:19 pm 
Getting Side Ways
Offline

Posts: 988

Joined: 4th Dec 2004

Ride: el faimont, dual fuel

Location: melbourne
VIC, Australia

smee wrote:
xpression wrote:
actually the water pump leak has been fixed, and if the car is serviced at ford the bonnet cable problem is rectified by a latch adjustment as part of a service...
http://www.mypage.tsn.cc/dave/Documents/water_pump.htm

thats basically a copy of the ford tsb on the fix for the water pump leak, and after i think mid 04 (dont quote me on the date) they changed the design of the pump and pipe.


Do you know if the new BA or BF pump fit the EF/EL's ?


ba water pump fits a au2 perfectly, i would 'think' it fits ef/el's, best to ask an experienced ford parts guy thats how we found out.

 

_________________

why do u write in here.

Top
 Profile  
 
 
Posted: Tue Feb 28, 2006 7:38 pm 
Tyre Shredder
Offline

Age: 30

Posts: 337

Joined: 23rd Feb 2005

Ride: BA XTS, BF Xr6 Turbo Ute

Location: Brisbane
QLD, Australia

Leroy wrote:
the big problems with BA's are the bonnet cables, hardly anything to get too upset about though lol. and the ever lasting coolant/water pump leak lol


yeh i totally agree with the bonnet cable thing, I have had no problem with my BA or BF with regards to the engine block. Biggest problem I have head with the two cars is a replacement throttle body sensor.

Ever considered the fact that maybe ford send the f**k ones over to NZ? Smaller market to service for . . . LOL :D

In all honesty I have a mate who is a mechanic here at one of the holden dealerships, and they had 6 VY GTS HSV's blow up on pre-sale testing by their mechanics during test drives . . . . now if you as me thats a big f**k problem ! ! !

I own a BF and a BA . . dont pay out on them, they are awsome.

 

_________________

Ford Fan: Since 1987 - Born a Blue Oval Supporter!

Top
 Profile  
 
 
Posted: Thu Mar 02, 2006 2:59 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

no way do the ecu's log anything of the kind.

the brake shudder fix for cars that exhibit the shudder are new pads and clips, but in 11/03 they changed teh callipers too
Top
 Profile  
 
 
Posted: Thu Mar 02, 2006 7:55 pm 
Stock as a Rock
Offline

Age: 32

Posts: 192

Joined: 8th Nov 2004

Gallery: 5 images

Ride: 08 ranger xlt

Location: Perth
WA, Australia

ive just dun ova 100,000kms wid my xr6 ute. no complaints.

 

_________________

IF ONLY MY GIRLFRIEND WAS AS DIRTY AS MY CAR

Top
 Profile  
 
 
Posted: Thu Mar 02, 2006 9:19 pm 
Oompa Loompa
Offline

Age: 44

Posts: 23

Joined: 5th Nov 2004

Ride: BA XR6 Mk1 sedan, KH Laser

Location: geelong
VIC, Australia

I've got no probs with my engine thats done 30000k's but i had the front tyres on my 03 xr6 replaced under warranty due the sidewall cracks. rang around a few local tyre dealers and said it was a common fault with that tyre not the car its fitted to. Other common probs with BA's that i know are brake squeal, park brake rubbing, interior fan bearing noisy. Mine has/had all these but still a fantastic car to drive

 

_________________

"Cos you know and i know better"
FORD ROCKS!!!!!!!
Rock On!!!!!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 4 of 4  [ 50 posts ]  Go to page Previous  1, 2, 3, 4

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 10:27 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names