Fordmods Logo

BA egas wagon playing up..... 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: BA egas wagon playing up.....
Posted: Thu Mar 12, 2009 1:11 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 30th Aug 2006

Location: warwick
QLD, Australia

Hi guys, I have an egas wagon that has started to play up in the last few months.
It started when i could'nt get it to start one night after work so we went down and got it to fire up by spraying WD spray down the intake pipe, it would run but only for a few seconds. Eventually it ran on its own and i talked to the local forklift/lpg mechanic who told be to pull apart the Landi converter and clean the solinoids, i found the start solinoid was quite gooed up and after assembling every thing again the car ran and started quite sweet. I then sprayed all inside the throttle body and in the 'gas ring' and lots more goo came out. I used a three bond TB cleaner foam. All seemed well in fact I was getting fantastic fuel economy at 9L /100k and all was well for a few days, then one morning I thought I'd turn up the idle a little, by turning out the small brass screw near the start solinoid half a turn and it didn't seem to change any thing, but, as I drove up the road it started to surge and the revs started to hunt between 500-1500rpm. I stoped and turned the screw back to where it was, but it still hunted alot. The next day I drove it on the highway it felt gutless and then played up alot as i drove in traffic, stalling and backfiring, and eventually the check engine light would keep coming on. I towed it home and took it to Ford to scan the PCM and the codes were:
P2100 Throttle actuator control circuit open
P2111 TAC stuck open
P2112 TAC stuck closed,
They think the grub screw on the TB had been tampered with and that will throw out the calibration, but if it had then it was like that when I got it.
new Throttle assembly w/tps & tac =$731.75

Q. can I change the Throttle actuator Control separately?
have I damaged the TAC from cleaning the TB?
any other ideas?
I'm also going to clean the tank solinoid and swap the 02 sensor and drop the cat.

cheers :|

 

_________________

behold I give you the RB40det!!!.....

Top
 Profile  
 
 
 Post subject: Re: BA egas wagon playing up.....
Posted: Wed Apr 01, 2009 12:20 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 30th Aug 2006

Location: warwick
QLD, Australia

Update is that i can get it to run if i hold the throttle open with a pen, so i have sourced another Throttle actuator, as a whole assembly 2nd hand, its a petrol one so im hoping to swap the motor over. The EGAS TB has an insert inside to feed the gas through though the rest looks the same.

 

_________________

behold I give you the RB40det!!!.....

Top
 Profile  
 
 
 Post subject: Re: BA egas wagon playing up.....
Posted: Wed Apr 01, 2009 8:58 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 56

Joined: 17th Jul 2006

Location: melbourne
VIC, Australia

theres a gas throttle body on ebay http://cgi.ebay.com.au/ws/eBayISAPI.dll ... 0306106998


have a look i got an au series 2 e gas had a similar prob i replaced the throttle body
Top
 Profile  
 
 
 Post subject: Re: BA egas wagon playing up.....
Posted: Thu Apr 09, 2009 12:50 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 30th Aug 2006

Location: warwick
QLD, Australia

:P Throttle body has been replaced by an Ebay special and is going good, it seems the brushes in the throttle motor just wore out...

 

_________________

behold I give you the RB40det!!!.....

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 6:10 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names