Fordmods Logo

Fordmods Advertising

Ba engine light hmm? 


Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

 Post subject: Re: Ba engine light hmm?
Posted: Thu Apr 05, 2012 4:06 am 
Oompa Loompa
User avatar

Posts: 21

Joined: 22nd Jan 2005

Ride: BA Futura

Location: Brisbane
QLD, Australia

It took about a week and it started doing it again. During that week the car drove as normal. First indication was the surging at light throttle. Once the throttle body was changed it was a new car.


 Post subject: Re: Ba engine light hmm?
Posted: Tue Apr 17, 2012 8:26 pm 
Stock as a Rock
User avatar

Age: 26

Posts: 184

Joined: 19th Oct 2009

Ride: BA XR6

Location: Melbourne
VIC, Australia

AussieXR6Grunt wrote:
REW93N wrote:
O2 Sensor, perhaps?
I know they bring up engine lights.

Hmm...anyway to rectify this problem?..It has happened one time long long ago when i booted it pure cold..she didnt like it and did the same thing lol..but it didnt happen again untill i just changed my snorkel..? :S You reckon it might need to get a second hand one from the wreckers?

Why the f&^k would you boot the engine pure cold that that most stupid thing you could do to an engine.
Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 15 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 3:54 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names