Fordmods Logo

Ba engine light hmm? 

 

Page 1 of 2 [ 17 posts ] Go to page 1, 2  Next

 
 Post subject: Ba engine light hmm?
Posted: Mon Mar 26, 2012 5:41 pm 
Stock as a Rock
Offline

Age: 26

Posts: 167

Joined: 21st Feb 2012

Ride: 2004 Ba Xr6

Location: Melbourne
VIC, Australia

So i bought a xr6 turbo snorkel to replace the stock ba xr snorkel for a little more air intake. Installed it no problems..but driving for about 5mins down the road the engine light comes on and the car goes lumpy..pulled over turned it off and started it again..all was good. Heading back from the shops almost near home the same thing happened again, turned off and turned back on.. Anyone got an idea of why this may be happening?..Little strange it just happened after i just changed the snorkel over the radiator.. :lol: It's gotta be somethin very mild but still not a good thing lol thx
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 5:42 pm 
Getting Side Ways
Offline
User avatar

Age: 24

Posts: 1006

Joined: 1st Oct 2010

Gallery: 14 images

Ride: EF XR8

Location: Richmond,
NSW, Australia

O2 Sensor, perhaps?
I know they bring up engine lights.

 

_________________

Blue blooded.

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 5:43 pm 
Stock as a Rock
Offline

Age: 26

Posts: 167

Joined: 21st Feb 2012

Ride: 2004 Ba Xr6

Location: Melbourne
VIC, Australia

REW93N wrote:
O2 Sensor, perhaps?
I know they bring up engine lights.

Hmm...anyway to rectify this problem?..It has happened one time long long ago when i booted it pure cold..she didnt like it and did the same thing lol..but it didnt happen again untill i just changed my snorkel..? :S You reckon it might need to get a second hand one from the wreckers?
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 6:11 pm 
Getting Side Ways
Offline
User avatar

Age: 24

Posts: 1006

Joined: 1st Oct 2010

Gallery: 14 images

Ride: EF XR8

Location: Richmond,
NSW, Australia

AussieXR6Grunt wrote:
REW93N wrote:
O2 Sensor, perhaps?
I know they bring up engine lights.

Hmm...anyway to rectify this problem?..It has happened one time long long ago when i booted it pure cold..she didnt like it and did the same thing lol..but it didnt happen again untill i just changed my snorkel..? :S You reckon it might need to get a second hand one from the wreckers?

I wouldn't guarantee that is the problem, but it sounds like it could be to me. Is it running rich?
Getting a new one wouldn't hurt anyway, and it would definitely be better than picking up a 2nd hand one that is already full of carbon etc.
http://www.ebay.com.au/itm/FORD-Falcon-AU-BA-BF-FG-FH-Territory-Explorer-Cougar-4-Wire-O2-Oxygen-Sensor-/150783567641?pt=AU_Car_Parts_Accessories&hash=item231b66a719

 

_________________

Blue blooded.

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 6:20 pm 
Stock as a Rock
Offline

Age: 26

Posts: 167

Joined: 21st Feb 2012

Ride: 2004 Ba Xr6

Location: Melbourne
VIC, Australia

Yeh it does have a little rough idle.. friend thought it was a miss but i replaced the spark plugs & it fixed it a bit but it does have little lumpiness on idle.. Id assume its still original o2 sensor, 150,000km previous owners didnt really know much about service..just had alot of money & a mechanic lol.. cougar brand any good? i heard bosch were pretty much the next best thing?
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 6:23 pm 
Getting Side Ways
Offline
User avatar

Age: 24

Posts: 1006

Joined: 1st Oct 2010

Gallery: 14 images

Ride: EF XR8

Location: Richmond,
NSW, Australia

AussieXR6Grunt wrote:
Yeh it does have a little rough idle.. friend thought it was a miss but i replaced the spark plugs & it fixed it a bit but it does have little lumpiness on idle.. Id assume its still original o2 sensor, 150,000km previous owners didnt really know much about service..just had alot of money & a mechanic lol.. cougar brand any good? i heard bosch were pretty much the next best thing?

yeah, Bosch is what you want, similar price I think. I just saw the first one on eBay and linked it, haha.
Or pay $440 for a genuine one!

 

_________________

Blue blooded.

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Mon Mar 26, 2012 6:24 pm 
Stock as a Rock
Offline

Age: 26

Posts: 167

Joined: 21st Feb 2012

Ride: 2004 Ba Xr6

Location: Melbourne
VIC, Australia

Lol no chance $440 :). Thanks for the info :D
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Thu Mar 29, 2012 5:58 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 493

Joined: 21st Sep 2010

Gallery: 3 images

Ride: BA XR6

Location: sydney
NSW, Australia

haven't heard of an oxygen sensor doing that, but then again if its really had it maybe. have a look in your manual to find out; which engine lights coming on. also is the light always on or just when shes in limp mode?
it sounds odd that its connected to putting a larger snorkel on your car. but clean your intake manifold and the filter.

ive had pretty much the same issue before but it was due to the electric motor that runs the throttle body starting to seize. allot of people have this issue and its the TPS (Throttle Position Sensor) thats the culprit.
dont take my word 100% as some of the parts like the TPS for example is quite expensive and would be money lost if its not the issue.

 

_________________

BA XR6
Performance mods: typhoon + territory pipe with K&N filter, full exhaust, BPR generic tune, lowered, xr6t front brakes, territory rear brakes
Visual mods: 19" rim, lower grill mesh, oil pressure and vacuum gauges, engine bay lighting, foot well lights
some of my main mods

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Thu Mar 29, 2012 6:57 pm 
Getting Side Ways
Offline
User avatar

Posts: 627

Joined: 5th Dec 2009

Gallery: 2 images

Ride: GREEN ED XR6

Power: 249 rwkw

Location: CENTRAL WEST QLD
QLD, Australia

you thought about changing the snorkel back to stock and see if it still does it?

 

_________________

AU2 engine with Hoppers head/cam performance package & spool rods / CP pistons ,Snort 1200 plenum, T56 Manual & Billet short shifter, Front & Rear Slotted rotors, Pedders lowered suspension, LSD and tuned with EMS stinger 4424 347rwkw THE ED XR6 IS BOOSTED

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Fri Mar 30, 2012 2:39 am 
Parts Gopher
Offline
User avatar

Age: 31

Posts: 93

Joined: 14th May 2011

Gallery: 8 images

Ride: Ford Falcon FG F6

Location: Perth
WA, Australia

I just posted this in another string so Ill attach mine here It sounds like he has the same problem as me!

This usually happens when I first start the car for the day, the car just about always stalls after a few meters down the road and the engine light comes on, but its a auto. Then I put it in Park turn the engine off and restart and good as new.

What ive noticed is when that happens my temp gauge is very cold at first but when I restart the engine the needle instantly goes up off the cold mark slightly. So I am assuming that the car is not passing its temp check and goes into limp mode.

Are there any problems that could occur if I just let it be?
The car did it before the custom tune so could it be the thermostat?

 

_________________

08 FG F6 #326. 4" Xforce exhaust turbo back with mid muffler delete, 1000cc injectors, 20% Underdrives, Stage 2 intercooler and piping, Stage 2 gear box, Upgraded flex plate, upgraded transcooler, upgraded fuel pump, Streetfighter air intake, cooler thermostate, SCT tune at 20psi at 406rwkw

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Fri Mar 30, 2012 6:35 am 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

I would look at the TPS. I had similar problems with our BA. First symptom was that i got done by a commodore once because the car refused to accelerate. I was thinking wtf. Felt like if had a governor on it. Then mrs went to start the car and it stalled and the engine light came up. Replaced TPS and never had a problem since. No engine light , smooth idle , and power always available. In fact the car drives that well lately its scary.
Also give the throttle body a nice clean with a dry rag. It makes a world of difference.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Sun Apr 01, 2012 5:03 pm 
Stock as a Rock
Offline

Age: 26

Posts: 167

Joined: 21st Feb 2012

Ride: 2004 Ba Xr6

Location: Melbourne
VIC, Australia

My cars running fine now lol..no issues..but i got a spare bosch O2 Sensor sittin in the glove box incase somethin does happen..
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Wed Apr 04, 2012 8:03 pm 
Oompa Loompa
Offline
User avatar

Posts: 21

Joined: 22nd Jan 2005

Ride: BA Futura

Location: Brisbane
QLD, Australia

I had a similar problem. First I felt the car surging at light throttle. I got worse quite quickly. It would then go into limp home mode, dropping cylinders. You could drive it but only with really light throttle, a small blip on the gas and the engine would cut out. Took it to Ford for a scan, 6 codes came up, all throttle body related. I changed the entire throttle body including all sensors, de coke the inlet, good as new. Try disconnecting the batt for 30 mins (computer reset) This worked for me but for a very short time.

Hope this helps

Cheers

Chris

2002 BA Futura auto. Bog stock
Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Thu Apr 05, 2012 2:23 am 
Parts Gopher
Offline
User avatar

Age: 31

Posts: 93

Joined: 14th May 2011

Gallery: 8 images

Ride: Ford Falcon FG F6

Location: Perth
WA, Australia

For a very short time? so it happened again?

 

_________________

08 FG F6 #326. 4" Xforce exhaust turbo back with mid muffler delete, 1000cc injectors, 20% Underdrives, Stage 2 intercooler and piping, Stage 2 gear box, Upgraded flex plate, upgraded transcooler, upgraded fuel pump, Streetfighter air intake, cooler thermostate, SCT tune at 20psi at 406rwkw

Top
 Profile  
 
 
 Post subject: Re: Ba engine light hmm?
Posted: Thu Apr 05, 2012 2:55 am 
Parts Gopher
Offline

Age: 34

Posts: 55

Joined: 20th Jan 2008

Gallery: 4 images

Ride: BF XR6

Location: PERTH
WA, Australia

My Bf does something similar, she needs to be warmed up before driving when starting from cold. I occasionally get an engine light. I did a diagnostic with my SCT tuner. It came up with running rich.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 3:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names