Fordmods Logo

ba series 1 cam solenoid questions 


Page 1 of 1 [ 1 post ] 

 Post subject: ba series 1 cam solenoid questions
Posted: Sun Jul 15, 2012 9:06 pm 
Parts Gopher

Age: 25

Posts: 84

Joined: 30th Dec 2010

Ride: BA Xr6

Location: Emerald
QLD, Australia

What are the symptoms of the solenoids gunking/playing up?
I know these were a problem but hasn't ford came up with a program they load into the ecu that purges them on start up?
Would these be causing my engine not to achieve peak torque?
My problem is that it feels as if my Variable Cam Timing isnt advancing and giving me the full acceleration, My mates same year model same gearbox (auto) xr6 rockets past mine when around the 3000 rpm range and mine just feels sluggish. Has anyone experienced this and can someone shed some light if possible. I have tried the usual things ie. coils, plugs , air filter, fuel filter , cleaning throttle body , cleaning fuel rail and pressure testing all came back alright btw. Again any help would be appreciated
Cheers Corey
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 26 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 29, 2016 11:03 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names