Fordmods Logo

ba xr6 turbo 


Page 1 of 1 [ 1 post ] 

 Post subject: ba xr6 turbo
Posted: Sat Oct 16, 2010 11:16 pm 
Fordmods Newbie

Age: 36

Posts: 7

Joined: 7th Jun 2010

Ride: xh splash ute

Location: emerald
QLD, Australia

i drove a standard (or so ive been told) xr6 today thats having problems, its the 5speed manual model, firstly, i was told a mechanic checked it out and it needs new plugs and leads, for a motor that runs fine then stops after getting under it, starts and thens runs rough for alittle bit then comes good.
I think its maybe computer management problems and limp home mode?
I've tightened the loose battery, degreased the engine (for me), started and went driving, first gear drive hits about 4grand and stops, restart, running rough(limp home?), stop, wait 20sec, restart, all good, drive out on open road second gear hit boost, pulls really hard from bout 2grand right out to 5500 or more with rather large surge and large amounts of black smoke at about 4grand 2 large puffs then haul all the way out to over 5grand and 200klm/hr .
what are ur thoughts im thinking to much boost/fuel issues, comp tuning something like that?
give me some food for thought something to check out, suggestions please!
im thinking its not standard cause my boss has a standard tornado ute and this thing would eat it,
under the bonnet looks standard(turbo ect) except for the pod filter.
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 12:27 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names