Fordmods Logo

BA XT Issue 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: BA XT Issue
Posted: Sun Jun 03, 2012 6:11 pm 
Stock as a Rock
Offline
User avatar

Age: 28

Posts: 184

Joined: 19th Oct 2009

Ride: BA XR6

Location: Melbourne
VIC, Australia

Drove the girlfriends car today and as I was half way down the road I lost nearly all power, it wasn't until I put the boot in and then the car came back to normal. Could it have been the TPS???
Top
 Profile  
 
 
 Post subject: Re: BA XT Issue
Posted: Tue Jun 05, 2012 12:34 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 2

Joined: 5th Jun 2012

Ride: 2003 Futura

Location: Perth
WA, Australia

that is possible but how old are the spark plugs, i had my car lose abit of power only to find out it was the spark plugs, get them checked
Top
 Profile  
 
 
 Post subject: Re: BA XT Issue
Posted: Sat Jun 09, 2012 1:27 pm 
Stock as a Rock
Offline
User avatar

Age: 28

Posts: 184

Joined: 19th Oct 2009

Ride: BA XR6

Location: Melbourne
VIC, Australia

BadAss 4D wrote:
that is possible but how old are the spark plugs, i had my car lose abit of power only to find out it was the spark plugs, get them checked


new Spark plugs and coil pack and o2 sensor installed less than 1000kms ago
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 5:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names