Fordmods Logo

Bigger cam from Tighe, Camtech, Crescent, Surecam, Wade? 

 

Page 3 of 5 [ 63 posts ] Go to page Previous  1, 2, 3, 4, 5  Next

 
Posted: Fri Jun 13, 2008 11:25 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 993

Joined: 26th Sep 2007

Gallery: 4 images

Ride: EL Fairmont Ghia

Location: Brisbane
QLD, Australia

my cam only "hunted" like that for a little while to the ecu learnt it. yours will prob be the same... my ISC was also not connected lol

 

_________________

ED Fairmont Barra 190rwkw 4.10 Gears 3500 Stall 1/4 to come

Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 11:22 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

edfairmont4.0 wrote:
my cam only "hunted" like that for a little while to the ecu learnt it. yours will prob be the same... my ISC was also not connected lol


ditto :D
and hasn't hunted since (over 6 months now)

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 2:51 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1442

Joined: 26th Apr 2006

Gallery: 6 images

Ride: 97 EL XR6

Power: 162 rwkw

Location: liverpool
NSW, Australia

cant go past CMS cams.

dont have the specs for you, but they are the only ones who do well at ALL of the drag and dyno days i have ever been to. 1st, 2nd and 3rd prize every time.

i am running a CMS stage 3, for a 14.4 @ 96mph, and averages around 155 rwkw and 375 nm at 5000rpm

my other mods are intake, extractors, exhaust, mild head work. still running standard ecu and standard bottom end.

 

_________________

07 BF MKII XR6T
310rwkw @ 13psi - Tuned By CMS

Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 9:21 pm 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

edfairmont4.0 wrote:
my cam only "hunted" like that for a little while to the ecu learnt it. yours will prob be the same... my ISC was also not connected lol


Been a few days now and cold starts are really f**k. Its not even hunting as such, but more half-stalling then revs to save it from dying.

Also have a nice pile of black soot behind where i park the car, idle is very rich, but at peak revs it seems to be lean with the o2 sensor showing 0.10 to 0.30 volts.

Looking at getting fuel/air ratios looked at, then will see if i need larger fuel regulator, then will get a tune done.

Very happy with the performance, just the cold starts are really annoying. Fuel usage is 8 litres/100km on the highway, but around town is shocking. Once i get the tune done and LSD fitted im looking forward to some decent numbers on the track..... hopefully :)
Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 9:49 pm 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

FAST-XR wrote:
i am running a CMS stage 3, for a 14.4 @ 96mph, and averages around 155 rwkw and 375 nm at 5000rpm


Thats a very good time, i'd be happy with that. Would be interesting to find out specs on his cams as they sound good.
Top
 Profile  
 
 
Posted: Tue Jun 17, 2008 11:49 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Yes a 110 LSA will be like an 18 year old on viagra..
Where a 114 LSA comes on a little early doesn't peak as hard as 110 but keeps pulling...
On a long stroke motor. A wider LSA may work better...
Don't get confused with cam centreline..

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Wed Jun 18, 2008 1:46 am 
Getting Side Ways
Offline

Age: 38

Posts: 668

Joined: 24th Jul 2006

Gallery: 4 images

Location: Geelong
VIC, Australia

yeh im currently running the 1673 cam has a very broad power curve but will be in the market for smthin a little more noticable from 2500-2900. Current set up netted me 143rwk at best but have a chiptorque chip and xr ecu along with 300kp fuel reg and bigger throttle body will see what all this combined gives me then next step will be head work with a better suited cam.

BTW fairmontxr6 love the idle sound of your car fantastic i want that kind of idle im guessing the bigger the cam the grumpier down low yes/no ?

 

_________________

EL Fairmont - GT steering wheel -3.45 lsd - superlows - white line sway bars - xr kit - au11 xr8 engine - 3500 convertor -BA XR8 leather interior - ltd woodgrain - di filippo extractors - trick flow track heat manifold - tfs1 camshaft - twin 2.5 inch system venom cats hooker mufflers - 187rwk

Top
 Profile  
 
 
Posted: Wed Jun 18, 2008 5:07 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

stoj79 wrote:
BTW fairmontxr6 love the idle sound of your car fantastic i want that kind of idle im guessing the bigger the cam the grumpier down low yes/no ?


Thanks mate :D
Yea, seems that way. Since I went from the factory XR cam to DEV 5 to my current Surecam.

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Wed Jun 18, 2008 5:10 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

FordFairmont wrote:
edfairmont4.0 wrote:
my cam only "hunted" like that for a little while to the ecu learnt it. yours will prob be the same... my ISC was also not connected lol


Been a few days now and cold starts are really f**k. Its not even hunting as such, but more half-stalling then revs to save it from dying.

Also have a nice pile of black soot behind where i park the car, idle is very rich, but at peak revs it seems to be lean with the o2 sensor showing 0.10 to 0.30 volts.

Looking at getting fuel/air ratios looked at, then will see if i need larger fuel regulator, then will get a tune done.

Very happy with the performance, just the cold starts are really annoying. Fuel usage is 8 litres/100km on the highway, but around town is shocking. Once i get the tune done and LSD fitted im looking forward to some decent numbers on the track..... hopefully :)


I also get the similar "problems" with it being rich below 4000rpm then starts to lean out. I belive this is because the map sensor is looking for factory vaccum pressure and is not finding it, thus trys to compensate, but makes it rich/lean...

I am currently looking at a few piggyback chips to fix this.

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Thu Aug 14, 2008 4:20 pm 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

FAST-XR wrote:
cant go past CMS cams.

dont have the specs for you, but they are the only ones who do well at ALL of the drag and dyno days i have ever been to. 1st, 2nd and 3rd prize every time.

i am running a CMS stage 3, for a 14.4 @ 96mph, and averages around 155 rwkw and 375 nm at 5000rpm

my other mods are intake, extractors, exhaust, mild head work. still running standard ecu and standard bottom end.


Could I run one of these CMS Stage 3 cams in place of my DEV 5?

Will it match well with the JMM ported head and JMM headers?

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 3:57 pm 
Oompa Loompa
Offline

Age: 33

Posts: 33

Joined: 30th Jul 2008

Location: Liverpool
NSW, Australia

yes no problems.

i think that with the amount of head work you have and a custom tune, providing that all is running ok, you will be pushing the 14.0 barrier...

call joe at crescent, 02 9600 6229...

 

_________________

CMS stage 3 cam, CMS stage 2 head, intake, extractors, exhaust...
standard bottom end, standard ECU
14.3 @ 96mph

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 4:06 pm 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

But will I still have the same chain rattle / guide probs?

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 4:14 pm 
Oompa Loompa
Offline

Age: 33

Posts: 33

Joined: 30th Jul 2008

Location: Liverpool
NSW, Australia

i have a slight rattle, but nothing too noticable unless you put your head under the bonnet and pull the throttle by hand, otherwise from in the car i cant hear anything, even standing outside of the car it can barely be heard... sounds like you have a big chain noise problem after reading your other thread!? how load is it?

 

_________________

CMS stage 3 cam, CMS stage 2 head, intake, extractors, exhaust...
standard bottom end, standard ECU
14.3 @ 96mph

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 4:27 pm 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

FAST-XR. wrote:
i have a slight rattle, but nothing too noticable unless you put your head under the bonnet and pull the throttle by hand, otherwise from in the car i cant hear anything, even standing outside of the car it can barely be heard... sounds like you have a big chain noise problem after reading your other thread!? how load is it?


It used to be really f**k loud, a real rattle easily heard from outside the car.

Then BPT found my broken chain guides, and worn timing cover ...replaced them, and she was a lot quieter except for a ticking lifter.

Had all my lifters replaced last week (along with belt tensioner pulley) ...but a ticking noise is still there, sounds like it's coming from the same spot as the dodgy lifter ...but it's also audible from somewhere under the car?

And I'm now getting a slight rattle again when revving at idle, and revving in lower gears ...seems to die down in 4th / 5th.

I've also noticed that my temp seems to be more prone to rising when revving her hard ...where it stayed pretty stable before.

It's got me stumped, and I don't wanna put some boost into her until I'm happy the motor is sound enough.

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 4:32 pm 
Oompa Loompa
Offline

Age: 33

Posts: 33

Joined: 30th Jul 2008

Location: Liverpool
NSW, Australia

does the dev 5 have too much duration for a boosted setup?

if you are planning on changing cams when it gets blown, id change it on your current setup to satisy yourself that the cam was/wasnt the problem, then go ahead with the boost... even though you will be underpowered till you go ahead with the boost....

 

_________________

CMS stage 3 cam, CMS stage 2 head, intake, extractors, exhaust...
standard bottom end, standard ECU
14.3 @ 96mph

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 5  [ 63 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: Google Adsense [Bot] and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:10 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names