Fordmods Logo

Blocked Fuel Filter? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Blocked Fuel Filter?
Posted: Sun Apr 24, 2005 10:59 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 496

Joined: 10th Nov 2004

Gallery: 5 images

Ride: EBII Fairmont Ghia

Location: Warragul
VIC, Australia

Yesterday I was driving with a heavy foot with a fuel light which was silly, I was almost home when the revs starting jumping around. I got home and the idle was jumping around and stalled. At the time I just went inside then later went and got fuel. Put it in and now when I start the car it's really rough and won't idle unless you hold it over 1000 and sputters and sounds terrible. The car was running fine prior to this this is why I suspect a blockage somewhere. Would the fuel filter be a possible suspect?

Thanks
Ben
Top
 Profile  
 
 
Posted: Sun Apr 24, 2005 11:10 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2976

Joined: 5th Nov 2004

Ride: BF Typhoon

Location: Melbourne
VIC, Australia

Could be, doesnt hurt to replace it either way.
How low on petrol DID you get?
Pump sound fine?

 

_________________

BF Typhoon, Dejavu - 6sp Auto, Leather, Sunroof, 19"s, Electric Pedals, Tint, FPV Sports Wheel, FPV Mats.

Top
 Profile  
 
 
Posted: Sun Apr 24, 2005 12:36 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 2637

Joined: 5th Nov 2004

Ride: EL TURBO GHIA

Power: 372 rwkw

Location: penrith
NSW, Australia

id replaced the fuel filter ,and if that doesnt help ,id replace ya fuel pump

 

_________________

HMMMM BOOST !!!


ED fairmont R.I.P

STREET FORDS FEATURE CAR ISSUE 42

Top
 Profile  
 
 
Posted: Sun Apr 24, 2005 3:16 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 496

Joined: 10th Nov 2004

Gallery: 5 images

Ride: EBII Fairmont Ghia

Location: Warragul
VIC, Australia

Well got RACV out and they said one of my injectors was stuck open, it was blowing heaps of black smoke like s**t loads. Well injectors are out, now I gotta wait till Tuesday as it's a long weekend, if anyone has ideas to clean or fix em that would be great. They were pretty dirty.

Ben
Top
 Profile  
 
 
Posted: Mon Apr 25, 2005 3:55 am 
Smokin em up
Offline

Posts: 280

Joined: 30th Mar 2005

Gallery: 2 images

Location: Melbourne
VIC, Australia

My brother in law has a old dual fuel magna.
He wouldn't run on petrol cause LPG was cheeper.
Well, it ended up no being able to run on pertol at all.
Seems the injectors got clogged up or dried out or whatever.

To solve this, i removed the injectors and partly imersed them in injector cleaner overnight (fluid did not cover the electrical plug).
Then i reinstalled the injectors, put a bottle of injector cleaner in the tank and filled with 20 ltrs of shell optimax.
Started on LPG took it for a drive and changed to petrol.
It coughed and spluttered for a minute but them came good.
Been running fine on petrol ever since.
Mind you, the car is down on power when on LPG since it is an old and poorly tuned system.
Do not that some injector cleaners recomend you change the oil after running a couple of bottles. I changed oil as it was well overdue.

This may or may not help in your situation but it could be worth a try.

Cheers.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names