Fordmods Logo

bloody car wont start after i degreased it grrr 

 

Page 1 of 3 [ 38 posts ] Go to page 1, 2, 3  Next

 
 Post subject: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:37 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

Hi all,
my ford fairmont ED 93 car had its motor degreased yesti after being hosed off it wont start but does crank, have changed the dizzy, could it be the fuel pump or starter motor as after being left over night tryed again after battery went flat so tried jumpin it an still no go......any ideras would be great, i have a ford futura 94 sitting here with all the parts i need (if they are the same?) someone plz help
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:44 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

i bet you either just had water in the dizzy or fried the coil. why did you even change the dizzy? is it timed correctly?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:44 pm 
Parts Gopher
Offline

Posts: 86

Joined: 23rd Dec 2009

Gallery: 16 images

Ride: ford ef2 xr6

Location: melbourne
VIC, Australia

Check your coil...they dont like getting wet
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:48 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

a mate is a mechanic an he came an changed it, the one that was in it was pretty f**ked..how do i check the coil? will the coil from a ford futura 93 fit it?
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:50 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

is the coil easy to change?? keep in mind i am a chick :lol:
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:50 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

TFI modules hate water...get some in there and it will fail.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:51 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

TFI modules :?: :?: what the hell is that
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 4:57 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

the TFI is a grey colour module that attaches to the side of the dizzy

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:04 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

yep found it i think its got wires comin out of it yeah :?: is it easy to change over an how do i do it
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:08 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

easier with the dizzy out :lol:

does it have spark?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:12 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

i tried putting a screw driver in the lead an there is spark...
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:44 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

is it strong and blue? or yellow?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:54 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

Strong blue
Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:54 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

well it's not a spark issue then. either fuel or timing. check the timing

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: bloody car wont start after i degreased it grrr
Posted: Sun Jun 05, 2011 5:59 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 18

Joined: 4th Jun 2011

Ride: Ford Fairmont

Location: Yea
VIC, Australia

think i mighta got the timing out by 1 hopefully if not i reckon the fuel pump...are they easy to change over an will my futura fit my fairmont??
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 3  [ 38 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: Google [Bot] and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Fri Dec 15, 2017 11:37 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names