Fordmods Logo

Bloody EA 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Bloody EA
Posted: Thu Dec 22, 2005 3:57 pm 
Tyre Shredder
Offline
User avatar

Age: 32

Posts: 366

Joined: 21st Nov 2004

Gallery: 9 images

Ride: BA Ford Fairmont 5.4L

Location: Gold Coast
QLD, Australia

Hey
Today the car wouldn’t start.....seemed like the battery was dead so I bought a new one and it still doesn’t turn over......

It’s like the starter motor tries a couple of times and then dies...or makes a really bad clicking sound....or does nothing....

I can still turn the motor over by hand.....anyone have any ideas.....

Cheers

 

_________________

Image
http://www.xcalibrestudios.com

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 4:00 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 3097

Joined: 5th Nov 2004

Gallery: 29 images

Ride: VU SS

Location: Ivanhoe
NSW, Australia

Probably dead starter motor.

 

_________________

EF Fairmont now Sold!
Guides: Polishing|Modifications |Manual Conversion

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 4:01 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Poor earth connection on engine, or power cable connection on starter motor.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
 Post subject: ???
Posted: Thu Dec 22, 2005 4:20 pm 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

Check the starter relay and the power to the coil. See if you can hear it click when you try to start the engine. Change the relay and see if that helps . you can use another relay from the car just make sure the contacts are the same as shown on the relay case and check the numbers underneath.
You could short out the solenoid on the starter to see if the starter turns. Otherwise check as the others have said.
Best of luck.

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 5:52 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

I had this problem, same thing. I thought it was the battery and then the starter motor, then the auto-electrician who drove to my house said it was all because the wiring had deterioated and there wasn't a good enough connection. And luckily he told me before i took a hammer to a perfectly good starter motor. 8-)

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 5:53 pm 
Tyre Shredder
Offline
User avatar

Age: 32

Posts: 366

Joined: 21st Nov 2004

Gallery: 9 images

Ride: BA Ford Fairmont 5.4L

Location: Gold Coast
QLD, Australia

all good now....went over all the wiring...cleaning and checking connections and it started.....was a lot of crap built up on everything....so all is good for now....thx for the replys

 

_________________

Image
http://www.xcalibrestudios.com

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 9:56 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 22nd Dec 2005

Ride: skyline_r34_gtr

Location: melb
VIC, Australia

yoo peepz,, iv had me EA 89 for bout 16 odd yearz now, and still running on Dual fuel, but derz one problem, itz got THEEEE Slowest Pick up u can imagine. It stalls when u press 2 cm of acceleration, u need to absolutely press the acceleration really slow in order for it not to stall , and after that the pick ups too slow. Plzzz sum one tell me wot could be the problem, Ive tried every mechanical repair i cud think of b4 takin it 2 the mechanics (wankers - rip offz). Mind u dat da car is Carby fueled, and doesnt hav a fuel rail. (CFI)

Me dad said derz water goin through the head gasket and into the oil, how do i fix this problem coz i know itz BIG ONE..
New motor??, replace gasket??, use SEAL-A-Heal??

plzz if u really luv ur EA's out there, please speak out..
Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 10:52 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1966

Joined: 13th Aug 2005

Ride: 2000 Au wagon

Location: some where in nsw
NSW, Australia

man the head gasket,like it needz to be replaced.

easy as,,can do it yerself for about $200 to $500.

man just do it.

 

_________________

Image

Top
 Profile  
 
 
Posted: Thu Dec 22, 2005 11:14 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2396

Joined: 25th Sep 2005

Gallery: 9 images

Ride: Da Maverick & xe ute

Location: Upper FTG. melbourne
VIC, Australia

yea do head gasket, service and tune on lpg and petrol, and then she shud run like gold again.

 

_________________

Mods: sprint kit, steeda short shift, svo lip, El handles, El Air intake, au xr wheels, lukey cat back, jbl focal and pioneer sterio <--- Sold

Xe ute - Bright green with 302

Da maverick - Straight gas turbo

Top
 Profile  
 
 
Posted: Mon Jan 02, 2006 4:23 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 22nd Dec 2005

Ride: skyline_r34_gtr

Location: melb
VIC, Australia

yeah thankx 4 ur help people,, i put in a new coil, and engine cutting out problem has fixed,,, but there still the problem that da car has no pik up at all, itz like dead at start off
Top
 Profile  
 
 
Posted: Mon Jan 02, 2006 4:33 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3772

Joined: 5th Nov 2004

Gallery: 33 images

Ride: EL Fairmont Ghia

Location: Hobart
TAS, Australia

steve_tdk wrote:
yeah thankx 4 ur help people,, i put in a new coil, and engine cutting out problem has fixed,,, but there still the problem that da car has no pik up at all, itz like dead at start off


head gasket mate you are getting water in your cylinders water aint so good for combustion
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 7:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names