Fordmods Logo

Brake Problems 


Page 1 of 1 [ 3 posts ] 

 Post subject: Brake Problems
Posted: Sat May 13, 2006 6:30 pm 
Parts Gopher
User avatar

Age: 28

Posts: 55

Joined: 29th Mar 2006

Location: Townsville
QLD, Australia

hey, as topic says i have brake problems in my 97' EL falcon.. coz this morning when i turned my car on and put my foot on the brake.. there was like a ahh "whooshing" sound coming from my brake pedal.. and now i have to apply the brakes really hard to actually get them to work.. and everytime i touch them there is whooshing noise.. so any help on what it could b would b greatly appreciated..
Posted: Sat May 13, 2006 10:24 pm 
Parts Gopher

Age: 50

Posts: 65

Joined: 3rd Dec 2004

Ride: 2005 BAII XR8

Location: Bundaberg, QLD
QLD, Australia

Perhaps a blowen brake booster diaphragm. Does the engine speed up or run rough with your foot on the brake?
Posted: Sun May 14, 2006 11:22 am 
Getting Side Ways
User avatar

Age: 52

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Yes I agree Brake Booster is stuffed.

Unplug the vacuum line to the booster and plug it. Start car, don't drive it! Then apply brakes and see if the whoosing sound has gone. If it has the booster is rooted and needs replacing.



She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 2:10 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names