Fordmods Logo

Cam install issues 

 

Page 1 of 2 [ 22 posts ] Go to page 1, 2  Next

 
 Post subject: Cam install issues
Posted: Tue Oct 24, 2006 7:43 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

i have had a rpd r3 for a while now.

note before i start i do not feel the cam is the issue now.

when it was professionaly installed, along with the valve springs and vernier that cam with the cam, it pulled 115rwkw@0' on the vernier . at +2' it did 105, at +5' it did 89rwkw. the car is GUTLESS upto 4000rpm (ie worse than stock, even top end feels worse than stock).

now, one thing i noticed is that the timing chain (new done during the cam install) rattled its head off all the time.

i decided to tinker with the cam, by retarding it to -2' and it seemed a little better. then i went to -5' and it feels much better uptop, and power comes on at 3000rpm now. BUT the biggest thing i noticed was that the timing chain is almost silent now, just rattles a tiny bit, can barly hear it.

i was wondering what this would hint to, as i would like to fix the problem and have it running ~140rwkw like other r3's for drag day.

P.S. sorry for long winded post.

Any help would be great,
Rushed.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 8:04 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 7029

Joined: 18th Apr 2005

Location: Hobart
TAS, Australia

Did you get hold of rpd first for advice?
if not, would it be a better idea?

 

_________________

Mind f**k!!! it works on feeble minded ignorant sheeples... there's plenty of em on this site... some are very intelligent but by god they are so thick!!!

Pakrat wrote:
You can buy them seppertly

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 8:07 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

yeah i have theyve been as helpfull as they can, but i was hoping for some advice as the cam install has cost WAY more than the cam/springs/vernier. and i dont want to allocate to much more money to it.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 8:11 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

Are the guides broken or overly worn and is the tensioner properly released?

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 8:14 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

stockstandard i was hoping for your advice as you are god of knowledge :)

mechanic said guides are fine, and the tensioner is where it should be.

could the cam have been put in way off seeing as the timing chain was done at the same time?

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 8:28 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

rushed wrote:
stockstandard i was hoping for your advice as you are god of knowledge :)

mechanic said guides are fine, and the tensioner is where it should be.

could the cam have been put in way off seeing as the timing chain was done at the same time?


Easy to check the tensioner - just pull the rocker cover off and see if the chain is loose on the drivers side of the cam (it pays to double check)

Sounds like the cam could have been put in a tooth advanced. That would explain the low power. The rattle was definately the timing chain and not some light piston to valve contact?

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 9:12 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 561

Joined: 23rd Dec 2005

Ride: XC V8

Location: Easten
SA, Australia

i actualy wrote an artical on how to change a cam about a year ago was going to post it up i'll see if i can find it as i had full pics with dravings and s**t was wicked spent houres on it i'll see if i can find it

 

_________________

1976 XC falcon
182 Clio Sport

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 9:18 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

my guess would be a tooth advanced as well..

I have run R3's with absolutly no issues at all. made good solid power.. I have the R6 now.. but that is not your issue.. sounds like a tooth. to retard that much is almost a complete tooth.

the guys say a little advanced but perhaps not that much, the 2 degree advance would be correct given its on the correct tooth.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 10:13 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

im thinking that it is off a tooth.

just out of interest how much timing advance should an EF have? whould putting the cam off a tooth stuff the timing up? cos on the dyno @ WOT it has 21' of timing advance. completely forgot to mention that.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 10:56 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

yeah skipping a tooth will make a big difference..
I think from memory my EF xr had about +3degrees timing if that helps.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Tue Oct 24, 2006 11:07 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

Im not sure exactly how much timing the EF's pull, but I suspect its in the high 20's so yours does sound low. At the same time having the cam gear off shouldnt directly change the timing as the EF's measure the engine position and set timing based on the actual position of the crank (before the timing chain gets involved).

How was the 21 degrees of advance measured?

Car isnt stuck in limp-home-mode is it?

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Wed Oct 25, 2006 12:46 am 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

not sure if its stuck in limp home mode.
the car has always been slowish, 16.08@89mph with full exhuast, and cold air, 3.23lsd,shiftkit.

the timing was measured on the dyno WOT, with a timing light. we didnt bridge the base timing thing though? would that help?

thanks for the help so far, as im really tring to get it running well for drag day.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Wed Oct 25, 2006 12:55 am 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

Nope dont need to bride the connection

You have to be very careful about reading the timing on the e-series falcons as they are very prone to slipping the outer ring of the balancer. You really cant trust that 21 degrees unless you check that the TDC mark on the balancer is correct.

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Wed Oct 25, 2006 1:30 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

i found that ef cams wont fit el's built after feb 98. (which i already knew but forgot)

an expencive way to find out

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
Posted: Wed Oct 25, 2006 12:48 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

so how would i fix this?

undo the cam bolt and move the vernier forward one notch on the chain?

i REALLY want this fixed by friday night. please help.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 22 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Metoikos88 and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names