Fordmods Logo

Car Dying On petrol 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Car Dying On petrol
Posted: Sun Oct 04, 2009 6:11 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Hey guys my 1993 Eb II has recently encountered a problem, all was fine with it and it runs dual fuel and i couldn't have been happier with it.

But then randomly i put it on petrol to give it a rub like i do once a fortnight and it just started shuttering, low revs then the car would die. I tried driving but i have to put my foot down more than normally and the car will still shutter. Then today i thought i would see what happened if i started it on petrol and just let it idle and the revs went high and then low then died, the second time i did this is didnt die but the revs kept going higher and lower to the point where it shutters

what could cause such a random issue?

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Sun Oct 04, 2009 9:08 pm 
Getting Side Ways
Offline

Posts: 625

Joined: 6th Nov 2004

Ride: R32 GTR

Location: Brackistan
VIC, Australia

peaandham wrote:
Hey guys my 1993 Eb II has recently encountered a problem, all was fine with it and it runs dual fuel and i couldn't have been happier with it.

But then randomly i put it on petrol to give it a rub like i do once a fortnight and it just started shuttering, low revs then the car would die. I tried driving but i have to put my foot down more than normally and the car will still shutter. Then today i thought i would see what happened if i started it on petrol and just let it idle and the revs went high and then low then died, the second time i did this is didnt die but the revs kept going higher and lower to the point where it shutters

what could cause such a random issue?


Sounds like the MAP sensor hose has been disconnected. Will run fine on LPG perhaps with a little f@rt at idle but petrol will run like s**t
Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Sun Oct 04, 2009 10:52 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Wheres the map sensor? and what does the hose look like ?

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Sun Oct 04, 2009 11:05 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

it will be on the left hand side of the engine bay (right side if looking toward the back).

looks like a little black box abot 8cm long, 4cm wide. has a plug and 1 (or 2?) small black hoses connected to it. the bottom hose is the one that blows off. reconnect that and all should be sweet.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Sun Oct 04, 2009 11:53 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

the isc may need a good clean out too. located on upper of intake mainfold, behind the throttle body. idle speed control
Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Mon Oct 05, 2009 12:29 am 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Ok sweet just had a read of my manual and tomorrow morning i will have a look at both ! Think i should also get myself a multimeter to measure the volts going into it !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: Car Dying On petrol
Posted: Mon Oct 05, 2009 9:02 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

New problem the MAP sensor hose seems to be fine but now the car will struggle the instant it fires up on petrol and die straight away ! Now i cannot drive my car, my thoughts are it could be the distributor or leads !

Please help !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 4:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names