Fordmods Logo

Car won't start at all! No power from battery 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Car won't start at all! No power from battery
Posted: Sun Apr 03, 2011 4:01 pm 
Getting Side Ways
Offline

Age: 29

Posts: 852

Joined: 15th Nov 2007

Location: melbourne
VIC, Australia

Hey guys

I have a EF fairmont. I just connected my amp and sub back up to my batt after a while not being connected. Everything was running sweet with the car on. I think decided to turn up the amp, I think it was frequency and bass boost. It was Ok for about a minute, went to the boot to check the sub and all of a sudden the music stopped, leaving the car running. I turned the car off and tried to start it again. Now the car wont turn on at all, not even to accessories. I think it may be a fuse. I checked the fuse box near my knee but all seem to be intact except for the air bag.

The fuses under the bonnet seem to be in tact except for a few that have a blue/white powder around some of the copper strip. I also cant take the main 100A fuse out. Not sure if that is normal, I also havent used alot of force trying to pull it out.

Guys not sure where to go from here, some help would be great.

Cheers
Daniel
Top
 Profile  
 
 
 Post subject: Re: Car won't start at all! No power from battery
Posted: Sun Apr 03, 2011 8:41 pm 
Getting Side Ways
Offline

Age: 29

Posts: 852

Joined: 15th Nov 2007

Location: melbourne
VIC, Australia

Ok, so found the fuse that blew

Its labeled CRT LP. Im just curious as to what this fuse is for? and is it wise to put a 15volt fuse in there instead of a 10

Cheers
Top
 Profile  
 
 
 Post subject: Re: Car won't start at all! No power from battery
Posted: Sun Apr 03, 2011 10:30 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

daniel000 wrote:
Ok, so found the fuse that blew

Its labeled CRT LP. Im just curious as to what this fuse is for? and is it wise to put a 15volt fuse in there instead of a 10

Cheers


I suggest you keep the recommended fuse size...don't go over unless you are really confident that the wiring won't melt before the fuse does.

EDIT: Also I am not sure what it stands for, but it is required for many things in the car, including starting the car I believe.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Car won't start at all! No power from battery
Posted: Tue Apr 05, 2011 8:04 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 251

Joined: 9th Sep 2009

Ride: ED falcon gli - XR6 replica

Location: Canberra
ACT, Australia

im pretty sure that fuse you mentioned is the interior light fuse but also has smart lock or coil or something shared on the same fuse. so if your car wont start, check if your interior light goes on or not

 

_________________

Ford ED Falcon Gli, T5 conv, Twinlight lights, exedy sports tuff clutch, modified EA front grill, ED XR6 complete interior, 19" speedy graphites, monroe gt shocks, kingspring superlows, CAI, ported tickford head, 3:45 LSD.
Soon: paccies, custom centre console

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 6:59 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names