Fordmods Logo

Fordmods Advertising

car wont run properly!! big problem 


Page 1 of 1 [ 3 posts ] 

 Post subject: car wont run properly!! big problem
Posted: Tue Sep 06, 2005 12:46 am 
Stock as a Rock
User avatar

Age: 32

Posts: 113

Joined: 5th Nov 2004

Gallery: 8 images

Ride: Futura

Location: Perth
WA, Australia

after a head gasket replacement my ED falcon ran for a day fine, then the next morning it went s**t and now misses under medium load or rev changes.

Ive checked the timing replaced the leads, got a new battery, new fuel pump, tried adjusting the timing chain a link each way (made it worse, so i put it back), and inspected coil and dizzy cap the rotor lines up with cylinder 1 at TDC and the nothc on the cam sprocket is ok) .

it takes a little bit longer to start than usual, and idles ok, but then under load or reving it misses and plays up.

ive tried resetting the computer. and checked voltages to all injectors, map sensor, TFI and coil.

ALSO i have noticed that the voltmeter in the cabin does not work, and the indicators dont flash when i unlock/lock the car with the smartlock pad.
(they work when indicating)
i wonder if this has anything to do with it,. (cos they werent like this before the car broke down)

Im getting desperate and really need the car. dont know what else to try .. any ideas would be appreciated..

im gonna try a new dizzy see if that helps but i doubt it will.




94 ED Futura, 5spd, RPM clutch,3.27 LSD, PH4480 pacemakers, 2.5'' Supercat, STG 2 Wade1004-112 advanced16degrees, XH intake K&N panel,pedders superlows, Expursuit puter. clearindicators, volvoTT thermofan
Alpine deck,splits,rears, clarion amp P1Crossfire subboofa, tint

Posted: Wed Sep 07, 2005 12:41 am 
Parts Gopher

Age: 44

Posts: 54

Joined: 17th Aug 2005

Ride: ef

Location: melbourne
VIC, Australia


check the earth strap from body to block.
Posted: Wed Sep 07, 2005 8:19 pm 
Oompa Loompa

Age: 31

Posts: 29

Joined: 2nd Dec 2004

Ride: ef fairmont

Location: perth
WA, Australia

mmm you have issues. and your car wont run properly :!:
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 8:06 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names