Fordmods Logo

Car Wont Start 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Car Wont Start
Posted: Tue Jul 29, 2008 6:52 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 2

Joined: 23rd Jul 2007

Location: Melbourne
VIC, Australia

Went to start up my car yesterday and it started then stalled almost instantley, since then all it does it turn over like an electric motor, dosnt really sound like it has compression either. Its a 2003 BA 6cyl aswell. Anyhelp would be appreciated
Top
 Profile  
 
 
Posted: Tue Jul 29, 2008 7:22 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

does the petrol pump prime the lines? If it doesn't check the relay for it or tap the fuel tank and see if it starts.

Sounds like the car started up fine with what ever fuel was left in the fuel line and then spluttered to a halt after it used it all up.

Though I am not sure with BA's if they have similar problems as E-series.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 2:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names