Fordmods Logo

clicking sound from engine 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: clicking sound from engine
Posted: Sun Apr 04, 2010 8:35 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

hey guys i have just recently put on some Pacemaker 4499 extractors and cat and now there is a ticking noise coming from the engine when ever im driving and its quite annoying at the moment, i just want to know what it is? and how do i solve this problem?

i do also have oil leaks one from the back of the engine and one from the front i was told they are front and rear seals have gone, the rear leak is around the back of the engine where it connects the gearbox and the one at the front is around the rocker cover, are these correct?

if anybody can please help me that would be much appreciated
thankyou
brett
Top
 Profile  
 
 
 Post subject: Re: clicking sound from engine
Posted: Sun Apr 04, 2010 8:49 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

ticking would be exhaust leak?? maybe lower flange or the gasket extractors to the head,did u fit them yourself or have a exhaust shop do it? if shop take it back

rear oil leak try rear main oil seal,possibly rocker cover
and front oil leak could be rocker cover , timing cover bolt, timing chain tensioner, crank- harmonic balancer seal,

degrease the front of the motor and check in a day or so to tell where for sure.
Top
 Profile  
 
 
 Post subject: Re: clicking sound from engine
Posted: Sun Apr 04, 2010 8:59 pm 
Smokin em up
Offline

Age: 28

Posts: 240

Joined: 5th Aug 2009

Gallery: 14 images

Ride: 1994 ford fairmont ED

Location: perth
WA, Australia

i fitted them myself and just used the original gasket that was on the car i did get another one that came with the extractors but didnt put it on, could it be that?
Top
 Profile  
 
 
 Post subject: Re: clicking sound from engine
Posted: Sun Apr 04, 2010 9:18 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Motivat-ed wrote:
i fitted them myself and just used the original gasket that was on the car i did get another one that came with the extractors but didnt put it on, could it be that?


yeah that could be the problem. shouldn't reuse gaskets. Put the new one on.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 4:38 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names