Fordmods Logo

Cold Start only, revs jump to 2000rpm, Choke ? 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Cold Start only, revs jump to 2000rpm, Choke ?
Posted: Fri Oct 26, 2007 9:21 pm 
Getting Side Ways
Offline

Age: 31

Posts: 462

Joined: 7th Apr 2005

Ride: EA

Location: Melbourne
VIC, Australia

Hey guys.

This has been a problem with my car for over a year, but ive never done anything about it till now. (EBII I6)

I'm fed up, it cant be good for my motor, but when motors cold (fresh moarning) , the revs once u crank it over, shoot to 2000rpm maybe even 2100rpm and then slowly creep down after 3-5 seconds to idle, BUT sometimes the basterd, sticks at 2000rpm and doesnt climb down at all! You have to jump in the car, put it in first gear, hold the brake, clutch in, and go to stall it for the revs to dip and be fine.

Ive been told its the automatic choke, but it cant be, its fuel injected, ECU controls choke....could the ISC be stuffed, i havent tried replacing it, but some moarnings its fine, and starts fine, but 90% of the time, it shoots to 2 grand and comes back down after 3-5 seconds.

Could it be the ISC sticking ? because once warm, car starts fine with no revs shooting up, but, let it cool down, and same problem repeats.

any comments will be appriciated !

- Grechie

 

_________________

Ford Falcon EA Naturally Aspirated 4.0L i6
13.797 @ 157.16km/h (Limiter Bounce)

1/4 Mile Video

Top
 Profile  
 
 
Posted: Fri Oct 26, 2007 10:38 pm 
Getting Side Ways
Offline

Age: 31

Posts: 462

Joined: 7th Apr 2005

Ride: EA

Location: Melbourne
VIC, Australia

i defently know its not:

MAP sensor
Vacuum leaks from anywhere

What it could be:
ISC sticking
coolant temp sensor (why?)
TPS (why?)

 

_________________

Ford Falcon EA Naturally Aspirated 4.0L i6
13.797 @ 157.16km/h (Limiter Bounce)

1/4 Mile Video

Top
 Profile  
 
 
Posted: Sat Oct 27, 2007 12:34 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 501

Joined: 25th Apr 2006

Ride: ED GLi Classic

Location: Ballarat
VIC, Australia

Could be the ISC. Take if off, put some turps in it and give it a shake.

If not, could be a sticking throttle springs, or possibly throttle cable. Unlikely, but possible.

 

_________________

RIP Chelsea
96 EF2 Gli - T5 / Exedy / Wade 977b / P+P / JMM Extractors, 2.5" / Port matched BBM / and more
bmICE

Top
 Profile  
 
 
Posted: Sat Oct 27, 2007 11:07 pm 
Getting Side Ways
Offline

Age: 70

Posts: 657

Joined: 24th Sep 2007

Gallery: 10 images

Location: Central Coast
NSW, Australia

Following Braidy, this may help
http://www.fordmods.com/forums/documents.php?doc=23
Paul

 

_________________

What goes around, comes around.

Top
 Profile  
 
 
Posted: Sun Oct 28, 2007 12:33 am 
Getting Side Ways
Offline

Age: 31

Posts: 462

Joined: 7th Apr 2005

Ride: EA

Location: Melbourne
VIC, Australia

ok, i tried new TPS, ISC, and Coolant Temp sensor, neither fixed it... great.

 

_________________

Ford Falcon EA Naturally Aspirated 4.0L i6
13.797 @ 157.16km/h (Limiter Bounce)

1/4 Mile Video

Top
 Profile  
 
 
Posted: Sun Oct 28, 2007 4:44 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2754

Joined: 14th Apr 2005

Ride: fairmont

Location: mackay
QLD, Australia

mine does it occasionly as well but not much lately it is strange and it does suck.... i am also curious wat it is

 

_________________

Now i have a EF XR8 5spd.........mmmmmm 5L

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot], wobbly and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 6:49 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names