Fordmods Logo

Did some mods, now... overfueling? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Did some mods, now... overfueling?
Posted: Sat Aug 08, 2009 10:28 pm 
Smokin em up
Offline

Age: 29

Posts: 200

Joined: 7th Apr 2007

Gallery: 19 images

Ride: XR6 XH Ute

Location: Narre Warren Sth.
VIC, Australia

Hi guys

Today I did some work on the ute, a '98 XH xr6. I swapped over the existing bbm for a ceramic coated item. I also changed the injectors for au 20lbs items and put on a bored out tb with the isc blocked off.

I made sure all my wires were back in there rightfull postions and everything is tight but it funs like a bag of s**t.

Basically at 2500rpm it pops and bangs out the exhaust and just gets worse with the revs kinda like its hitting the limiter. My old man stuck his head underneath(exhaust is dumped at diff) and said its blowing black smoke and smells very rich, so we thought the injectors. We have changed them back and maybe marginally better but not fixed by along shot.

So now I'm looking for Ideas on what to look for. We have had fuel lines,vac lines and wires off today so any of these could be the problem, maybe someone could tell me what to look at.

I will take it for a run tomorrow and see if it picks up and try changing the tb back to standard.

Please Help

Cheers
Ben
Top
 Profile  
 
 
 Post subject: Re: Did some mods, now... overfueling?
Posted: Sat Aug 08, 2009 10:37 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

did you re connect the vac hose to the map sensor??
Top
 Profile  
 
 
 Post subject: Re: Did some mods, now... overfueling?
Posted: Sat Aug 08, 2009 11:22 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

TROYMAN wrote:
did you re connect the vac hose to the map sensor??


Yeah I agree with Troy check the map sensor vac line, by the sounds of it with the popping and blackish smoke this is the prop.

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
 Post subject: Re: Did some mods, now... overfueling?
Posted: Sat Aug 08, 2009 11:30 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 673

Joined: 29th Jan 2006

Gallery: 8 images

Ride: BA XR6 Turbo

Location: Canberra
ACT, Australia

+1 for vac hose.

I remember when fitting a 71mm Yella Terra TB to a mates VR commy we left this off. Lots of fuel / black smoke pumping out the back, and idle was very low, (actually sounded pretty lumpy!) but we knew something was right, it didn't want to rev.

 

_________________

I like boost
http://www.venomexhaustworks.com.au

Top
 Profile  
 
 
 Post subject: Re: Did some mods, now... overfueling?
Posted: Sun Aug 09, 2009 7:19 pm 
Smokin em up
Offline

Age: 29

Posts: 200

Joined: 7th Apr 2007

Gallery: 19 images

Ride: XR6 XH Ute

Location: Narre Warren Sth.
VIC, Australia

Vac hoses were all connected. We accidentally knocked the plug out the bottom of the map which is really hard to notice on an XH
So you were pretty close

Thanks alot guys you gave me any area to look at, it really narrowed it down

If you have alot in the garage section you can see my new intake on the ute

Thanks alot
Ben
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 10:20 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names