Fordmods Logo

EA 5 speed won't start, immobiliser? Starter motor? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EA 5 speed won't start, immobiliser? Starter motor?
Posted: Tue Jun 11, 2013 7:53 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 4

Joined: 17th Oct 2010

Ride: xf falcon ute lol

Location: geelong
VIC, Australia

Hey ladies and gents just brought myself a EA S PAC but it won't turn over, can't hear the fuel pump prime or nothing I've put jumper leads on because the battery's flat everything lights up works etc but when I turn the key nothing no fuel pump nothing no starter nothing.... Can hear the relay working when i turn the key though. Has a little alarm led looking light next to the demister switch, but I found a switch under the dash which disarmed it or at least made the light stop... Ideas? Thought it was a starter motor but won't even roll start!!
Top
 Profile  
 
 
 Post subject: Re: EA 5 speed won't start, immobiliser? Starter motor?
Posted: Tue Jun 11, 2013 9:34 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
 
 Post subject: Re: EA 5 speed won't start, immobiliser? Starter motor?
Posted: Tue Jun 11, 2013 10:09 pm 
Getting Side Ways
Offline
User avatar

Age: 51

Posts: 433

Joined: 18th Jul 2009

Ride: NL FAIRLANE BA TURBO POWERED

Location: ballarat
VIC, Australia

Check ignition switch. Check if ignition and start circuit are getting power.
Top
 Profile  
 
 
 Post subject: Re: EA 5 speed won't start, immobiliser? Starter motor?
Posted: Tue Jun 11, 2013 10:53 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:17 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names