Fordmods Logo

EA driving me insane-oil light, rattling. 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EA driving me insane-oil light, rattling.
Posted: Sat Dec 06, 2008 8:07 am 
Parts Gopher
Offline

Age: 28

Posts: 76

Joined: 23rd Sep 2007

Gallery: 4 images

Ride: EA fairmont GHIA

Location: Port Macquarie
NSW, Australia

ok..I'll give you guys the full story so you know whats happened to the engine and so on. Oh btw its a 5spd 3.9mpfi

up until January this year the car has been running fine stock.
In Late Jan, i put a wade cam (1673) in it-including the shims that wade cams sourced for me as my ford dealer is pathetic and a rip off. Anyways it had a little bit of light ticking. Just thought it was the lifters settling in new shims and all that so gave it a bit of time, then it wouldnt go away.
So we took of the rocker cover and found that a timing chain guider had broken (f**k) so yeahi was driving around for a while with a broken guider and potential sloppy timing chain. i hadnt driven too much this year as i've been overseas.

In august i got a manual ECU and decided to get it all fixed. and in the process found that one of the valves in cylinder 1 had been hitting the piston. We put this down to a loose timing chain and hoped that it would stop wen the new one went in. So we got the timing chain set in the car, shaved the head slightly and new head gasket on, got it all correctly lined up, had the car running. so it was cool (for now).

Next was the thermo fans. The way we set it up was just put a sensor (rated to switch on at 90C and turn off once temp reached 85-86) in the top of the thermostat housing running to a relay where the 2 fans are wired so they both come on. On the temp gauge the needle is horizontal wen the fans kick in (on the EA fairmont type gauge).

So after this i did a service and changed fuel and oil filters (both ryco replacement filters) and did a oil change. We put synth S in it (10W-40) which i was using for a little bit but drained it out and put fresh mobil super 1000 15W-40 in it with another new ryco filter.

THE PROBLEM:- the ticking has gone away(must have been timing chain). But now whenever the car has been running for a little bit and is hot, the oil light starts to flicker on at low rpm (around 600). It idles at around 1000 normally, only when its hot does the idle fluctuate and drop to 600 (hence the oil light coming on and beeping on the computer all the time). now as soon as it gets to the temp that this light comes on, the engine feels sloppy and gets a rattle to it.
If i keep driving around, like on a trip somewhere or driving around town, the rpm of which the oil light and warning noise comes on gets higher and higher, to the point where it wont even idle at normal speed without the light being on. I can feel a noticeable difference in the engine performance and it is driving me insane. It doesnt go away until I let the engine cool down completely.

note: i am going to try and get some pictures of the gauge and where it sits wen the light comes on.

Thanks in advanced for any help you guys can provide.

 

_________________

5spd EA Fairmont GHIA, lowered Kings all round, 2.5" exhuast w/extractors, 3.45 LSD, Wade 1673 regrind cam, Alpine stuff inside

Top
 Profile  
 
 
Posted: Sat Dec 06, 2008 10:40 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

it sounds like the bootom end bearings are on there way out...
try a thicker oil. like penrite hpr 30 or 40..
it will help with oil pressure but unfortunatly it sounds like your engine is on its way out..
although my old ea engine had this problem and i used thicker oil and it helped heaps ..the engine lasted another 12 months before the bearings got real bad...
Top
 Profile  
 
 
Posted: Sat Dec 06, 2008 8:49 pm 
Parts Gopher
Offline

Age: 28

Posts: 76

Joined: 23rd Sep 2007

Gallery: 4 images

Ride: EA fairmont GHIA

Location: Port Macquarie
NSW, Australia

hmm.....thats not the answer i wanted...

well next question....what engines can u run with the mpfi3.9L manual ECU? can u run any 4.0L up to ED? would be good if i could get say a ed xr6 motor and work on it til my one carks it then dump new engine in.

 

_________________

5spd EA Fairmont GHIA, lowered Kings all round, 2.5" exhuast w/extractors, 3.45 LSD, Wade 1673 regrind cam, Alpine stuff inside

Top
 Profile  
 
 
Posted: Sat Dec 06, 2008 9:35 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

you can run any e series engine..but the easiest swap over is ea,eb,ed,xr6 ect..
and the ea mpfi ecu will run them all fine..even the xr6 engine..
it will perform a little better with the xr6 ecu but will still run fine with the 3.9 one..
Top
 Profile  
 
 
Posted: Sun Dec 07, 2008 7:24 am 
Parts Gopher
Offline

Age: 28

Posts: 76

Joined: 23rd Sep 2007

Gallery: 4 images

Ride: EA fairmont GHIA

Location: Port Macquarie
NSW, Australia

interesting....this could end up being a project that results in something productive.
just a few q's:

1. Just to clarify, EA-ED use log manifold and EF-EL use the BBM?

2. Do any E-series use coil packs or are they all distributor setups.

3. If i was looking at an ED XR motor would an upgrade in anything to do with the fuel system be required?

4. Could I use the wiring loom from current engine?

thnks troyman for your time and answers so far.

 

_________________

5spd EA Fairmont GHIA, lowered Kings all round, 2.5" exhuast w/extractors, 3.45 LSD, Wade 1673 regrind cam, Alpine stuff inside

Top
 Profile  
 
 
Posted: Sun Dec 07, 2008 9:17 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

E4fairmontGHI4 wrote:
interesting....this could end up being a project that results in something productive.
just a few q's:

1. Just to clarify, EA-ED use log manifold and EF-EL use the BBM?

2. Do any E-series use coil packs or are they all distributor setups.

3. If i was looking at an ED XR motor would an upgrade in anything to do with the fuel system be required?

4. Could I use the wiring loom from current engine?

thnks troyman for your time and answers so far.



hi
yes ea-ed use the log manifold and ef-el use the bbm.

ef is the only e series that uses coil pack. ea,b,d and el use dizzy..

if you use a ed xr motor you dont really need to upgrade anything..
the ed xr6 from factory does use the different ecu and fuel reg but its not essential. the engine will still run good on std ecu and reg..
keep in mind that the xr engine is the same as std except for cam,head,fuel reg and ecu. the bottom end,manifold ect is the same as your ea.

and yes you can use the loom from your current engine..
Top
 Profile  
 
 
Posted: Mon Dec 08, 2008 2:07 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

In fact you will HAVE to use the loom from your current engine and the throttle body as well.

I have just done this swap over the weekend, an ED engine into an EB1 wagon. The EA/EB1 loom is different to the later EB11 and ED arrangement. Just compare them carefully and swap the bits from you old engine, ie throttle body and log manifold loom, and it will all be sweet.

Cheers and good luck

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
Posted: Mon Dec 08, 2008 9:42 pm 
Parts Gopher
Offline

Age: 28

Posts: 76

Joined: 23rd Sep 2007

Gallery: 4 images

Ride: EA fairmont GHIA

Location: Port Macquarie
NSW, Australia

cool..thats handy info...i was just checkin out rocket industries website and they have an ACL race series rebuild kit specifically for the 3.9L available. I sent them an email on the retail of this kit, hopefully i can get it through our worskhop for a bit cheaper..but do you reckon im better off takin what i got out and rebuilding it (Its only done just over 200k kms) then trying to find another tired engine that could potentially screw up again.

 

_________________

5spd EA Fairmont GHIA, lowered Kings all round, 2.5" exhuast w/extractors, 3.45 LSD, Wade 1673 regrind cam, Alpine stuff inside

Top
 Profile  
 
 
Posted: Mon Dec 08, 2008 10:35 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

it depends how much money your willing to spend??

if you have a tight budget than maybe try get a second hand ef/el engine as it will fit straight in fairly easy...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 2:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names