Fordmods Logo

ea ford - recent head change - running like .. really bad 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: ea ford - recent head change - running like .. really bad
Posted: Sun Feb 18, 2007 5:36 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 11

Joined: 19th Jan 2007

Ride: 1998

Location: Brisbane
QLD, Australia

g'day all

ok just finished the head changeover on my ea (it took some time i know)

turned it over and it's running rough but sounds ok at idel but while driving it's surging, and the temp gauge and speedo keep jumping all over the place.
the breaks are tough to use now like there's no vacume behind them.

any help would be apreciated

88 ea 3.9 cfi dule fule everything else is stock

although it hasn't been run on pertol in a few years
(previous ownre disconected the fule pump) so i'm guessing the carby needs some work.


thanks
dingstock

 

_________________

"I need 5L of fule, a box of matches and a holden, STAT" mike Murphy

Top
 Profile  
 
 
 Post subject: Re: ea ford - recent head change - running like .. really b
Posted: Sun Feb 18, 2007 6:32 pm 
Stock as a Rock
Offline

Posts: 156

Joined: 15th Jun 2006

Ride: XH Ute

Location: Leinster
WA, Australia

dingstockea wrote:
g'day all

ok just finished the head changeover on my ea (it took some time i know)

turned it over and it's running rough but sounds ok at idel but while driving it's surging, and the temp gauge and speedo keep jumping all over the place.
the breaks are tough to use now like there's no vacume behind them.

any help would be apreciated

88 ea 3.9 cfi dule fule everything else is stock

although it hasn't been run on pertol in a few years
(previous ownre disconected the fule pump) so i'm guessing the carby needs some work.


thanks
dingstock



Can you go back to gas, to see if it is ok on that.
Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 6:39 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 11

Joined: 19th Jan 2007

Ride: 1998

Location: Brisbane
QLD, Australia

won't run on petrol (guessing the injectors need to be uncloged)

so right now it's only running on gas

 

_________________

"I need 5L of fule, a box of matches and a holden, STAT" mike Murphy

Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 6:42 pm 
Getting Side Ways
Offline

Age: 51

Posts: 720

Joined: 18th Sep 2005

Ride: ef fairmont

Location: orange
NSW, Australia

see if you have got all the earths on. and see if all vacum lines are on as well .keep us posted
Top
 Profile  
 
 
Posted: Sun Feb 18, 2007 6:45 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 11

Joined: 19th Jan 2007

Ride: 1998

Location: Brisbane
QLD, Australia

where am i looking for the earths?

and all vacume hoses that i disconected were hooked back up to the same spot


update:

been back over evrything and i can't see anything that's not connected

 

_________________

"I need 5L of fule, a box of matches and a holden, STAT" mike Murphy

Top
 Profile  
 
 
Posted: Mon Feb 19, 2007 10:18 pm 
Oompa Loompa
Offline

Age: 41

Posts: 24

Joined: 16th Jul 2006

Gallery: 1 images

Location: melbourne, bayswater
VIC, Australia

sounds like a vac leak, get a spray bottle of water and squirt it around the inlet manifold and any vacuum lines while the engine is idling and listen for a change in engine speed cos if theres a leak it will suck the water in. also follow the thick vac line from the brake booster all the way to its end and make sure its connected.
Top
 Profile  
 
 
Posted: Thu Mar 01, 2007 12:21 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 11

Joined: 19th Jan 2007

Ride: 1998

Location: Brisbane
QLD, Australia

yep vacume leak it is lost half the thread on the vacume cupling (white plastic thingy) on the inlet manifold

$16 from ford for another plastic one

Anyone know of metal ones being used and if so where to get one in brisbane?

thanks for the help

Dingstock

 

_________________

"I need 5L of fule, a box of matches and a holden, STAT" mike Murphy

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: johnnyeHCF and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:32 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names