Fordmods Logo

EA slight surge at cruise 


Page 1 of 1 [ 3 posts ] 

 Post subject: EA slight surge at cruise
Posted: Tue Oct 02, 2007 12:38 pm 
Stock as a Rock

Age: 35

Posts: 112

Joined: 18th Aug 2005

Location: hobart
TAS, Australia

Hi, i have an ea falcon 3.9 manual MPI, the problem i seem to have is that at light cruise speeds, around 50-60km's/hour it seems most noticable there seems to be a subtle surge in the engine. it isn't enough to really rock the car or anything but you can just feel it. I'd say it feels like a subtle lean surge but i can't figure out why. Fuel pressure is fine and i can't find any vacuum leaks. Any ideas on what i can look at or what may be a possible cause of this?
 Post subject: fuel
Posted: Tue Oct 02, 2007 2:43 pm 
Fordmods Newbie

Age: 31

Posts: 8

Joined: 29th Sep 2007

Ride: ea falcon

Location: melbourne
VIC, Australia

get your injectors cleand or your computer might be on its way out.
but id check the injectors first.
 Post subject: surge
Posted: Tue Oct 02, 2007 2:56 pm 
Parts Gopher

Age: 57

Posts: 89

Joined: 15th Apr 2005

Ride: EL Fairmont Wagon

Location: Riyadh
QLD, Australia

My 91 EA with thottle body injection did just that, it got slowly worse until a couple of full blown engine hiccups happened.
I put new plugs,leads,dizzie cap and rotor, and it was like a new car again.
I also sprayed the whole T/B area with T/B spray cleaner from autobarn to remove the carbon buildup they suffer from quite badly .
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 29, 2016 5:25 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names