Fordmods Logo

eb 4L wont rev past 4grand 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 12:59 am 
Fordmods Newbie
Offline

Age: 27

Posts: 2

Joined: 17th Dec 2009

Ride: ford eb

Location: perth
WA, Australia

hi
i have a eb fairmont with 4l auto
recently got the head recond and put new top end gaskets in
it will not rev past 4000 rpm it did this before i recond the head as well, i thought that it had just lost comp but its all fix !
one thing i noticed today is 2 hoses coming out of the fire wall passengers side.
they look like some sort of vacume hose one is green and the other black may be totaly unrelated
just wondering what the problem could be?
the timing is correct i have replaced the leads, new spark plugs, rotor button and dizzy cap
i tried resetting the ecu but that didnt have any effect on it
any ideas?
Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 6:32 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2098

Joined: 5th Nov 2004

Ride: egas bf xt

Location: Gosford
NSW, Australia

Blocked cat?

 

_________________

I can see through wooden doors.

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 9:11 pm 
Smokin em up
Offline
User avatar

Age: 27

Posts: 236

Joined: 4th Jan 2009

Ride: ED XR6, AUII XR8

Location: Melbourne
VIC, Australia

might be worth trying a different fuel pump.

 

_________________

ED XR6, LeMans Red, 5-Speed
AUII XR8, Silhouette, 5-Speed

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 9:19 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Heaps of things to check, fuel pressure, blocked exhaust ( CAT, mufflers, ect ), injectors, dizzy, ignition coil, base ignition timing, cam timing, slipped harmonic balancer, inlet gasket vacuum leaks, O2 sensor.........ect.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 11:33 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

BLOCKED FUEL FILTER!

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Fri Dec 18, 2009 11:49 pm 
Getting Side Ways
Offline
User avatar

Posts: 1043

Joined: 7th Feb 2005

Location: Canberra
ACT, Australia

Check your accelerator cable, they stretch over time

 

_________________

1993 ED XR6 5speed Polynesian Green. Project car.

1998 EL XR8 Auto Hot Chilli Red. New daily and project

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sat Dec 19, 2009 1:38 am 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

I'll suggest fuel filter as well, is the car breaking down when it get to 4k?

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sat Dec 19, 2009 8:26 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1833

Joined: 3rd May 2007

Gallery: 8 images

Ride: AUII XR6 Uterus

Location: South Coast
NSW, Australia

+1 for check cat and fuel pump.

and how much power and torque do stock ebs make over 4k?

 

_________________

Not to get technical, but according to chemistry alcohol is a solution.

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sat Dec 19, 2009 9:19 am 
Oompa Loompa
Offline

Posts: 44

Joined: 25th Nov 2009

Ride: Ford Falcon GLi sedan

Location: sydney
NSW, Australia

map sensor hose not connected,cracked, or loose?
Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sat Dec 19, 2009 10:32 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 9

Joined: 12th Oct 2008

Ride: eb gli, s13 silvia sr20det

Location: SA-ThA-DRiFT-StATe
SA, Australia

is the throttle cable on the right linkage? it should be on the inside 1. i had the same thing not longago and thats what it was

 

_________________

My Toys
1989 N13 Langley 18le+turbo(first car will never sell)
1992 EB11 xr6 (crashed)Daily
1992 EB11 gli (swaping parts from xr6 )Daily
1993 S13 Silvia SR20 turbo (weekender)
1999 kawisaki kx 125 motocross bike
2001 yamaha yz 125 motocross bike

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sat Dec 19, 2009 10:49 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 251

Joined: 9th Sep 2009

Ride: ED falcon gli - XR6 replica

Location: Canberra
ACT, Australia

under load or free revving or both?
i know it'll be loud as F**k but un flange the exhaust before the cat and start it up to eliminate the exhaust. then if not, clamp of the return line from the fuel rail/reg and then try rev it, could be pump on its last legs or blocked fuel filter. my mate had the same problem with his old liberty it would stop revving while driving hard about 4,300rpm. turns out the air filter looked like it was a bag of potting mix.

 

_________________

Ford ED Falcon Gli, T5 conv, Twinlight lights, exedy sports tuff clutch, modified EA front grill, ED XR6 complete interior, 19" speedy graphites, monroe gt shocks, kingspring superlows, CAI, ported tickford head, 3:45 LSD.
Soon: paccies, custom centre console

Top
 Profile  
 
 
 Post subject: Re: eb 4L wont rev past 4grand
Posted: Sun Dec 20, 2009 9:30 pm 
Fordmods Newbie
Offline

Age: 27

Posts: 2

Joined: 17th Dec 2009

Ride: ford eb

Location: perth
WA, Australia

its not timing or cam timing
the criuse control works
it only revs to 4k free (neutral) and under a load it will rev to almost 4 in first but less in other gears and doesnt make much torque
cleaned the air filter
it is getting full throttle
will check the fuel filter and if its not that will check the exhaust
uniacidz wrote:
Black one goes to underneath the manifold ono the vacuum tree on the top and the green one goes on the same vacuum tree on the end side.

If they are not connected, you wont get cruise control if installed and front air con vents default to the demisters.

Should still rev past 4k though but try anyway.


that would explain why the air con doesnt work cheers for that:)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 9:27 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names